Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

RC Signal Lost permanently after firmware upgrade

Discussion in 'Standard/4k Discussion' started by DividedSky, Aug 15, 2016.

  1. DividedSky

    Joined:
    Aug 15, 2016
    Messages:
    24
    Likes Received:
    8
    All, just upgraded my firmware to the latest version today on my P3S (not sure where to check the firmware version in the app?) I'm assuming I need to find the directions how to link the RC back to the P3S, but wanted to ask if this is a known bug/issue that anyone else has experienced? I took a screen shot after they would not sync up, have rebooted everything - RC, the drone, etc.
     

    Attached Files:

  2. WilliamM

    Joined:
    May 30, 2016
    Messages:
    796
    Likes Received:
    215
    Location:
    Lancaster, Pa.
    Yes, sometimes when you do a FW update you need to relink the RC with the drone.
     
  3. WilliamM

    Joined:
    May 30, 2016
    Messages:
    796
    Likes Received:
    215
    Location:
    Lancaster, Pa.
    The easiest way is after everything is powered up, push the relink button on the drone till it turns red. Have the Go app booted up already, and have the relink option on screen. Then just hit relink on the Go app while that light is still red, and it will change to green once done. And the large LED light on your RC should also be green at that point.
     
    DividedSky likes this.
  4. DividedSky

    Joined:
    Aug 15, 2016
    Messages:
    24
    Likes Received:
    8
    Will do, I'll give it shot. Thanks to both for the quick reply
     
  5. flpholt

    Joined:
    Jan 27, 2016
    Messages:
    4,178
    Likes Received:
    1,561
    Location:
    palm harbor florida