Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3A SIGNAL LOST at 1500m for 1m21s but RTH not initiated?

Discussion in 'Pro/Adv Discussion' started by t0mb0la, May 17, 2016.

  1. t0mb0la

    Jan 11, 2016
    Likes Received:
    Manchester UK

    I was trying to better my non-record breaking 1777m distance, but failed on this attempt.
    After a couple of adjustments to overcome low signal warnings, I decided it would be better to bring the drone home.
    On the return, about 1500m away @ 4m33s after take-off, total signal loss; no telemetry or live view.
    I shrugged and proceeded to wait for the RTH, assuming I'd hear the familiar sound soon enough; watching for the red status on the RC to return to green and video to reappear.
    Just over a minute later, and my signal returned, but the aircraft was still hovering where I'd lost signal.
    I guided it home myself and landed.
    I checked my settings before take off, return home altitude was correct - signal loss should "return to home" and smart return home was enabled.
    How come RTH was not automatic?
    If the signal hadn't returned after more than a few minutes, I would have used the RTH on my controller.
    Still, I am concerned that my drone could have just stayed hovering there, until 30% battery, and then just landed where it was.
  2. lookin4pain

    Dec 25, 2015
    Likes Received:
    I had a similar issue
    Video signal was lost, RC signal was still present so my rth never kicked in.

    To test, send your bird out and turn your RC off.

    Sent from my iPhone using PhantomPilots mobile app
  3. ryantrax

    Jul 14, 2015
    Likes Received:
    Xenia, Ohio
    Make sure your RTH setting in the DJI Go is set to "Smart Return Home" not Hover or Land. Sounds like yours is set to hover.
    EDIT: Ooops sorry just re-read you had it enabled. Definitely sounds like some closer range tests should be done to see how it performs, take it out 100m and hit the RTH button and see if it works or turn off the RC.