Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Failsafe Homing

Discussion in 'General Discussion' started by Ots, Jun 13, 2013.

  1. Ots

    Ots

    Joined:
    Jun 12, 2013
    Messages:
    77
    Likes Received:
    1
    Location:
    So Cal
    Is there a way to see the Phantom perform auto home, like it should do in failsafe, without forcing it into failsafe by turning off the Tx, for example?
     
  2. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Yes... follow these steps: (geek solution tested) :ugeek:

    1) Ge a buddy for making telephone coordination ;)
    2) Unmount the 4 propellers (don't like flyaways)
    3) Turn on TX as normal procedure (here your could begin to film phantom).
    4) Power on Phantom in an open field and wait for full satellite GPS lock, Home Lock Record... etc.
    5) When get GREEN flash LED only, start motors and leave them on at low speed, as if you where hovering (flying)
    6) Now your buddy must drive away (by car) carrying the TX on (you keeps talking by telephone to your buddy)
    7) Some place far from phantom (depending on blocks, trees, distance) your TX will lost communication.
    8) You will nottice that on phantom. Alert to your buddy for comeback. Phantom will begin RTH failsafe (motors will speed up ...)
    9) When your buddy return to your place set ATTI mode on TX (for regain control). Test moving joysticks until phantom increase-decrease motor speed.
    10) Perform the "LAND" procedure and shut off motors then shut off TX. (here you can stop filming).

    Now you can enjoy the video and full test safely if your phantom activates RTH failsafe. This method is tested and works great. Phantom "thinks" is returning home but really TX is comming near, so thats all. :ugeek:
     
  3. Ots

    Ots

    Joined:
    Jun 12, 2013
    Messages:
    77
    Likes Received:
    1
    Location:
    So Cal
    Ok, I was hoping for the ability to watch it fly back to home though. Also, as I understand it, if it's less than 20 meters high it first climbs above 20 meters before traveling home.

    Thanks.
     
  4. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    That's certainly an elaborate, yet safe way to test it out!

    If you're a little wary about RTH,. don't be., it really does work.
    the only times you really hear about it not working is usually when someone is experiencing other difficulties that it cannot overcome. (GPS issues, NAZA gyro problems, too much wind..loss of power,.etc)

    -well first off, you can connect the Phantom to the NAZA and enable failsafe in the third position of GPS/ATTI switch.
    -enable IOC and read up about how to use CL/HL
    -view the settings in the NAZA while it's connected to the Phantom and look what happens when you do toggle that switch down, it should say "Failsafe" on the bottom.

    Take the Phantom out to a nice wide open field, start it up and ensure that you see the 20x green blinks
    (you can manually re-set home location by toggling between CL and HL 10 times as well, as well as reset course position by toggling between CL and Off 10 times).

    -Fly your Phantom about 100 feet out and try using HL, no matter where it is, or what direction it's pointed, is should fly back towards you when you pull the right stick back. Then you'll be reassured that the Phantom thinks your starting location is the home position.

    - and then to test out RTH,. fly out a hundred feet away, and toggle the GPS/ATTI switch to the lower Failsafe position. and viola, it should automatically fly back towards you., while still being connected to the Tx.
    .. then just flip back to ATTI to regain control. (be sure Throttle is at 50% of course, or the Phantom will drop)
     
  5. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    That is correct.
    just be sure to avoid flying behind areas of really tall trees or buildings!
     
  6. Ots

    Ots

    Joined:
    Jun 12, 2013
    Messages:
    77
    Likes Received:
    1
    Location:
    So Cal
    Good.

    But is there a way to demonstrate the phantom returning home in failsafe without actually losing signal with it?
     
  7. TJSPhantom1

    Joined:
    Jun 13, 2013
    Messages:
    4
    Likes Received:
    0
    I'm new to the forum, but have been flying my Phantom for a few weeks now. I have been trying to set/test the failsafe mode with the GPS/ATTI/ATTI switch, setting the third position to FAILSAFE. I have repeated this a few times already, but the Phantom only seems to drift off when I try it. I have verified the HOME position by using the Home lock mode and flying the craft in a circle around me holding the right stick to left/right. Pulling down also make it travel back toward me.

    I noticed your comment about showing "Failsafe" on the bottom. The drop down menu shows FAILSAFE, but when I pull the switch to that position, the mode displayed at the bottom of the NAZA-M V2 application shows "MODE: Failsafe". It changes to "GPS Atti" and "Atti" in the other positions, but does not go to "Failsafe"

    Any suggestions? Thanks!

    Update to post: ISSUE FIXED with firmware upgrade from 3.00 to 3.12
     
  8. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    I don't quite follow.

    Does the NAZA indicate that you're in Failsafe mode when you enable it and move the switch down?

    You can also test the switch, as the LED indicated on the Phantom should slowly blink Yellow indicating it's in failsafe (it will blink like that as well if you turn off the transmitter)
     
  9. TJSPhantom1

    Joined:
    Jun 13, 2013
    Messages:
    4
    Likes Received:
    0
    Thanks for the reply. Sorry if I was confusing...

    I think the short answer to your question is NO, but being new to the system and application, I'll try to be detailed on what I did - in case I did something wrong.

    1) I had programmed the switch for Failsafe before I tried to test it out, yesterday.

    2) I went out into a field, powered it on and warmed it up before take-off. I put the control into HL mode and flew the craft for a couple of minutes. It flew as expected for HL, so I know the home position was valid.

    3) Then, when I tried to put it into Failsafe using the switch, the craft drifted slowly, in the general direction of the wind. It did not return to the home position that I had just verified in (2).

    4) Now, I have the craft connected to the NAZA-M application, and again verified the dropdown selection as Failsafe for the GPS/ATTI/ATTI switch-down position. The slider and the blue highlight in the application move as I change the switch positions, as expected.

    4a) Also, as I change the switch between the 3 positions, the "MODE:" text (shown near the bottom left corner of the NAZA-M application, just to the right of the green and blue LED indicators) shows "GPS Atti." (with the switch at top position), then "Atti." (with the switch at middle position), and "Atti." again (with the switch at the bottom position). *** I think the text should show "Failsafe" when I put the switch to the bottom position.

    So, based on the MODE status being displayed, it appears the control mode is not going into Failsafe when I put the switch down but rather stays in ATTI mode (which makes sense to me why it drifts when I try to test the failsafe mode).

    5) Lastly, if I turn off the transmitter power, the "Mode" text does show "Failsafe".

    Update to post: ISSUE FIXED with firmware upgrade from 3.00 to 3.12
     
  10. TJSPhantom1

    Joined:
    Jun 13, 2013
    Messages:
    4
    Likes Received:
    0
    In response to your suggestion on the craft's LED - I just took the craft outside and powered it on in GPS mode with HL/CL modes off (both switches in up position).

    1) After the warm-up period, the LED blinks once GREEN - GPS mode, has GPS lock, ready to fly.
    2) I changed the switch to the middle position (ATTI), and the craft LED blinks once YELLOW - expected for ATTI.
    3) I changed the switch to the lower position (should be Failsafe), and the craft LED blinks once YELLOW - same as ATTI.

    Note: I don't think it makes a difference, but want to point out that I did not power on the motors - in case it does make a difference for the test.

    4) When I turned off the radio, the craft LED blinks rapidly YELLOW.

    Update to post: ISSUE FIXED with firmware upgrade from 3.00 to 3.12
     
  11. GeneL

    Joined:
    Apr 19, 2013
    Messages:
    104
    Likes Received:
    1
    Location:
    Northern California
    Amen to that, Gizmo! Watch out for that throttle with RTH.

    Yesterday I was setting up a shot and intended to switch to ATTI and let the Phantom coast with the wind for the duration. However, I must have already been in ATTI when I pulled back the switch, because the bird immediately started an unexpected rapid climb. Reflexively, I pulled off the throttle to stop that nonsense, but nothing happened.

    Around about the time I verified that I really, really had no control, the Phantom started back toward me and it started to sink in that it was, however it happened, in RTH. This was pretty much confirmed when it started a descent, but I still had it in my head that I wanted control, so I flipped the GPS/ATTI switch upward. Well, I got control all right - still with zero throttle - and my Phantom took on the flight characteristics of a brick plummeting right at my head, or so it looked like.

    Fortunately, I was able to jam the throttle to the stops just in time to arrest the fall right before the crash. When I got my wits back, my Phantom was placidly hovering at eye level ten feet in front of my nose, patiently waiting for further instructions from it's so called "pilot."

    That was my first experience with RTH, and it caught me by surprise. Still, in my opinion, the throttle is the most dangerous control on the box (besides the pilot, of course) :roll:
     
  12. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
     
  13. TJSPhantom1

    Joined:
    Jun 13, 2013
    Messages:
    4
    Likes Received:
    0
    ISSUE FIXED: 3.00 FIRMWARE UPGRADE TO 3.12

    Well, it turns out that you need to login when you start the NAZA-M application for it to tell you if there are any updates.

    I had an error when I first loaded the application (v2.12) and tried to log in. I never went back to redo it and have just been hitting Cancel when the dialog would pop up. You got me thinking about what the latest version is, with your comment on the 2-blink green when it is ready to fly, and found people talking about 3.10 and 3.12 - mine was older, but the application showed "No Updates" for firmware versions until I registered.

    After registering and updating the firmware, the application shows "Failsafe" in the third switch position, etc. All seems to be working.

    I just took it out to the park and flew it with no issues. I tested the Failsafe switch 3 times - twice from a low altitude and once from high altitude. It works as described by everyone else, and is amazing to watch.

    Thanks so much to you, Gizmo, for responding and helping me out. I really appreciate it.
     
  14. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    Grooovy! glad you have it sorted out.

    these quads are complex little machines
    easily 10x more complex than I thought it would be!

    but kinda fun tinkering with everything!