Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Continue to get rare "Ultrasonic Systems Error" window. Has not flown the same since latest firmware

Discussion in 'Phantom 3 Help' started by David Tolsky, Apr 25, 2016.

  1. David Tolsky

    Joined:
    Jan 27, 2016
    Messages:
    78
    Likes Received:
    5
    My compass calibration works fine and GPS locks in after after a short warm up period which I never even saw before the last firmware upgrade. My flights are not stable in the wind anymore and the aircraft starts to drift immediately. I had much more stable flights before. Contacted Drone Nerds who sold me my P3A back in January at CES. They said the Ultrasonic error is rare and they don't see it much. They said it could be due to a dirty sensor or defective part. I've been flying since January though without any problems until now. I want to avoid DJI customer service at any cost. Any ideas would be greatly appreciated.
     
  2. David Tolsky

    Joined:
    Jan 27, 2016
    Messages:
    78
    Likes Received:
    5
    Update: was told by DJI to calibrate the IMU. When I went to do that I got "does not need calibration" I calibrated anyway indoors. Does anyone know what numbers should be in the sensors Windows on the calibration menu? Most of mine show zeros


    Sent from my iPhone using PhantomPilots mobile app
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Do you fly indoors or less than 3m height?? If not, turn it off.
     
  4. David Tolsky

    Joined:
    Jan 27, 2016
    Messages:
    78
    Likes Received:
    5
    I'm intrigued by this Mako79. Please explain how to do so.