Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Buzzing on startup

Discussion in 'Pro/Adv Discussion' started by tjlt123, Jul 17, 2015.

  1. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    I have just received my P3A. Upon first power up (not motors), there is a loud buzzing noise from the gimbal. Is this normal?
    I had a P2 before but this buzz is much louder.
    Many thanks
     
  2. acherman

    Joined:
    Oct 20, 2014
    Messages:
    497
    Likes Received:
    237
    Location:
    Alberta, Canada
    Have you removed both the clear plastic guard and the white foam at the back top of the gimbal?
     
    JBG likes this.
  3. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    Yes
     
  4. acherman

    Joined:
    Oct 20, 2014
    Messages:
    497
    Likes Received:
    237
    Location:
    Alberta, Canada
    Does the gimbal go through a power up self test and swing all over a couple of times freely? When powered off does it flop around with zero resistance?
     
  5. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    It works perfectly but there is just a very loud low frequency buzz. I'm about to update it and see if that makes any difference.
     
  6. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Its the fan, don't worry about it.
     
  7. acherman

    Joined:
    Oct 20, 2014
    Messages:
    497
    Likes Received:
    237
    Location:
    Alberta, Canada
    DON'T UPGRADE YOUR FIRMWARE!!!!!!
     
  8. Robin Slater

    Joined:
    Jun 17, 2015
    Messages:
    55
    Likes Received:
    10
    Location:
    Tamworth
    No mate I have a P3a and have no sound at all from the gimbal other than the twisty start up dance when it initialises. Is the noise constant? Make sure you take the packing and the gimbal clamp off before start up
     
  9. acherman

    Joined:
    Oct 20, 2014
    Messages:
    497
    Likes Received:
    237
    Location:
    Alberta, Canada
    Sorry , had to get that in quickly. What firmware are you running? Please, before you upgrade, read all of the complaint threads about newer firmware. Don't end up being one of the ones bitching and complaining that firmware broke your aircraft and now you're stuck with something that doesn't fly.
     
  10. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    I am also unable to connect to the app, it just says disconnected. However I read that I need to be on the a higher firmware to do so. Could I have just been sold a dud?
     
  11. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    Yeah just a constant buzz.
     
  12. Waxings

    Joined:
    May 11, 2015
    Messages:
    126
    Likes Received:
    13
    I had the same issue and it seemed to vibrate enough to cause a video problem. I returned it and my new one is perfect. No issues.
     
  13. tjlt123

    Joined:
    May 27, 2015
    Messages:
    37
    Likes Received:
    1
    Location:
    Salisbury, UK
    Can I just confirm, should it be making any noise at all when idle?
     
  14. Ken Cruise

    Joined:
    Jul 11, 2015
    Messages:
    140
    Likes Received:
    54
    Location:
    Winston-Salem N.C.
    Archerman have you been waiting for someone to make a post with the word Buzz in it? lol
     
  15. acherman

    Joined:
    Oct 20, 2014
    Messages:
    497
    Likes Received:
    237
    Location:
    Alberta, Canada
    Haha No, just don't want to see another person upgrade and end up with a pretty paperweight.
     
    Ken Cruise likes this.