Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Anyone else thinking about staying at 1.3.2 forever?

Discussion in 'Pro/Adv Discussion' started by Alex_, Nov 23, 2015.

  1. Alex_

    Joined:
    Jul 9, 2015
    Messages:
    82
    Likes Received:
    31
    Location:
    Littleton, CO
    With all the discussions around GEO, etc. I never upgrade to 1.4. Also helped that I've been traveling a lot lately and haven't had that much time to fly. But now I'm starting to think maybe staying at 1.3.2 isn't the worse idea if I don't want to deal with personal NFZ's, etc down the road. (I've also got auto update on my iPad off so I'm on a pretty old version of the app as well).

    When waypoints came out they weren't that compelling.. but some of these newer apps like FPV and Airnest look like they are more on point. Maybe I go to 1.4 so i can use those and then stop?

    My daily reading of this forum hasn't been able to happen as my schedule got busier so I apologize for what I'm sure may repetitive questions.

    Thanks for any perspective you can share to help me make this decision.

    Alex
     
    meringueman likes this.
  2. Bigskyflyer

    Joined:
    Jun 14, 2015
    Messages:
    117
    Likes Received:
    71
    Location:
    SW Montana
    Alex, I am still on 1.3.20 and have no plans to update. Everything works perfect as is. I am still running the dji pilot app and it still works great also.
     
    Mr.Spock and Alex_ like this.
  3. TC Malker

    Joined:
    Nov 3, 2015
    Messages:
    297
    Likes Received:
    85
    I only went to 1.4.1 because I wanted to try out the new features (follow me, waypoint, etc.). Don't know if I will upgrade to next firmware 1.5.3...Actually I might do it, as long as I can downgrade back to 1.4.1
     
  4. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,748
    Likes Received:
    3,459
    There's a popular school of thought on the forums that would have you believe that:
    DJI is evil and wants to restrict everything about how you fly
    No firmware since version 1.0.0 is any good and every new version brings new restrictions​
    But evidence to back up this popular opinion is either very scarce or non-existent.
    It would be good if flyers looked for fact-based evidence rather than kooky conspiracy theories when making decisions.
    eg ..
    Instead of being swayed by some forum members' opinions (of varying accuracy) think, find out what the real issues are.
    If you are interested to know what's really planned look at this:
    DJI GEO Coming to Your P3 In Dec | Page 10 | DJI Phantom Forum
     
    Innrkid and III% Streve like this.
  5. Bigskyflyer

    Joined:
    Jun 14, 2015
    Messages:
    117
    Likes Received:
    71
    Location:
    SW Montana
    I didn't read any conspiracy theories on this thread. The only reason I am staying at 1.3.20 is everything I need or want works flawlessly. If it ain't broke no need to try to fix it.
     
  6. Bob Denny

    Joined:
    Aug 12, 2015
    Messages:
    78
    Likes Received:
    17
    Location:
    Mesa, AZ
    Everything that's in the old firmware that is. DJI have greatly expanded the capabilities of your quad with software updates.
     
    Meta4 likes this.
  7. JKDSensei

    Joined:
    Jun 24, 2015
    Messages:
    1,511
    Likes Received:
    658
    Location:
    USA
    Alex,
    I'm still on 1.3.2 also. AFAIK, you never "have" to update. If you like your firmware, you can keep your firmware.
    A good way to go about this might be to look at the list of changes (I'm not sure where to find it but it's here somewhere), that way you can decide for yourself if you want to upgrade.
    Good luck.
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Never is a long time:D
     
  9. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,144
    Likes Received:
    1,659
    Location:
    San Francisco, CA
    Life of each phantom is only few years, enjoy the way you want to.

    I will keep updating and if there are issues, write them in forum as there are experts to resolve them.
     
  10. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,244
    Likes Received:
    1,614
    Location:
    Palm Beach Co.- FL
    As long as there is a proprietary battery there will be the possibility of forced upgrades.
     
    bobmyers likes this.
  11. rhoffart

    Joined:
    May 11, 2015
    Messages:
    406
    Likes Received:
    189
    Location:
    Boerne, Texas
    I'm always one the first to update firmware ... I always keep all my electronics up to date with the latest firmware. My tv, xbox, iPhone, Macbook, Harmony remote, wifi thermostat all require updates ... and this is just what I can see from where I sit.
     
    transmetaman likes this.
  12. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Some of the reasons why folks cant update and have issues upgrading are probably a result of not upgrading previously or staying with the current upgrade program. IMHO
     
  13. rhoffart

    Joined:
    May 11, 2015
    Messages:
    406
    Likes Received:
    189
    Location:
    Boerne, Texas
    There is a big conspiracy theory that as iPhones get older the updates make the battery die quicker. :)
     
  14. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    :D:D:D:D
     
  15. III% Streve

    Joined:
    Aug 1, 2015
    Messages:
    1,756
    Likes Received:
    515
    The problem with that train of thought is that you have no idea if its working properly unless YOU are the one that created it. You know you cant tell me that it isnt broke. Because every update comes with at least SOME fixes!
     
  16. rdc4444

    Joined:
    Nov 30, 2014
    Messages:
    96
    Likes Received:
    11
    Are you sure that staying on firmware 1.3.2 will keep the upcoming geofencing from taking effect? I thought dji said the new geofencing will be included as part of a mandatory update. Even if your on 1.3.2 it sounds like you won't be able,to fly unless you update the firmware. Correct me if I'm wrong. If this is the case I'll downgrade back to 1.3.2
     
  17. III% Streve

    Joined:
    Aug 1, 2015
    Messages:
    1,756
    Likes Received:
    515
    What is it about Geo Fencing that you are concerned about?
     
  18. rhoffart

    Joined:
    May 11, 2015
    Messages:
    406
    Likes Received:
    189
    Location:
    Boerne, Texas
    FAA registration and GEO Fencing are both coming. There are going to be thousands added after Christmas but 3/4 of them will be busted by New Years Day :)
     
    Reed L likes this.
  19. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,748
    Likes Received:
    3,459
    Rather than formulating opinions based on uninformed heresay or forum chatter and spouting absolute nonsense, you guys would be a lot better off if you just checked the FACTS.
    You have no idea of geofencing, no idea what you are talking about.

    Go and check this post and watch the video to find out what the real situation is.
     
    III% Streve likes this.
  20. III% Streve

    Joined:
    Aug 1, 2015
    Messages:
    1,756
    Likes Received:
    515
    Forgot the link boss! Here is the video that would be at the link