Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Trouble Connecting to Wifi

Discussion in 'Phantom 2 Vision Help' started by SaintKelley, Dec 17, 2013.

  1. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    Can't consistently connect to brandnew Phantom 2 Wifi that I bought from B &H photo.

    I have the following problem. I turn on the copter....then I turn on the range extender. After I do this its "POWER" button turns solid green. The "SYSTEM" button next to it turns a blinking green light which lasts for maybe 45 seconds before it goes solid green. My new Iphone 5s cannot see the Phantom network at this point.

    Then I wait. Sometimes its 5 minutes....sometimes its 15 minutes....(sometimes its never and I give up for that day) then suddenly the "System" light on the range extender starts to blink and all of a sudden the Phantom network pops up on my Iphone 5s and I can connect to the wifi and fly.

    This is INCREDIBLY frustrating as it is a complete crapshoot every time I go out to try and fly whether I will be able to or not. The last two times that I got it to connect and flew it, I flew it about 200 feet away from me when it "Lost Connection" and flew itself home.

    I am wondering if the Range Extender is bad. Has anybody else had this problem with a solid/blinking (not connecting/then maybe connecting) SYSTEM button in the manner that I have? Any suggestions would be incredibly frustrated. I am ready to throw this thing against the wall!!!!!!!!!!!!!!!
     
  2. TheFlyingSentinel

    Joined:
    Dec 10, 2013
    Messages:
    33
    Likes Received:
    2
    Hi ...

    what happens when you leave the Range Extender off ? Do you have then the same issues ?

    Reason of my question is ... Basicly the Range Extender is nothing else then an WIFI Repeater. On these very short distance you should have an fine WIFI signal even when the Range Extender is off ... If not ... I would say something is wrong with your Phantom 2 Vision or the iPhone ...

    cheers,

    Nik
     
  3. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    I did not realize that you could connect to the PV's WiFi without the Range Extender being ON, I will have to try to connect my phone directly to the copter (and with the range extender OFF) after work this afternoon.

    Has anybody else had this issue, though, with their Range Extender "SYSTEM" light blinking upon turning it on, then going solid for a long indeterminate period, and then starting to blink again out of the blue? I may be barking up the wrong tree here, but that seems weird.

    Thanks for your reply. I appreciate it!
     
  4. TheFlyingSentinel

    Joined:
    Dec 10, 2013
    Messages:
    33
    Likes Received:
    2
    From what I know ...

    the P2V Cam is sending standard 802.11g WIFI in Infrastructure mode ... So it should be possible to connect without the range extender ...

    cheers
     
  5. LeoS

    Joined:
    Nov 25, 2013
    Messages:
    747
    Likes Received:
    1
    1. Upgrade your camera's firmware and make sure the smartphone app is on the latest version. I believe it addresses most inconsistent connection issues.
    (While you're at it, make sure the phantom and transmitter are also up to date on all firmware updates).

    2. When you experience a broken connection that results in return-to-home, that's the transmitter (5.8ghz). Different frequency than the one used by fpv/osd (2.4ghz).
    FYI 5.8ghz frequency needs line of sight to work and generally has shorter range compared to 2.4ghz on the same power.
     
  6. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    Thanks LeoS.

    This might be a really stupid question, but how do I verify if I have the latest smartphone app version? I opened the app but I don't see anywhere that lists the version that I have installed.

    I have installed all updates on the copter and controller.
     
  7. LeoS

    Joined:
    Nov 25, 2013
    Messages:
    747
    Likes Received:
    1
    On iOS you just need to go to the AppStore and check for updates. I'd imagine it's the same on google play store?
     
  8. joejoda

    Joined:
    Dec 26, 2013
    Messages:
    11
    Likes Received:
    0
    I am having the same problem connecting to the wifi extender to my iPhone. I have also had the network show up, but when I go to connect it tells me that we are unable to connect. I have called drone fly and they are trying to help me. They think the extender is defective. Anybody have any suggestions? :?:
     
  9. LeoS

    Joined:
    Nov 25, 2013
    Messages:
    747
    Likes Received:
    1
    Make sure you have a microsd card on the camera and the card works fine (test it on your computer).
     
  10. joejoda

    Joined:
    Dec 26, 2013
    Messages:
    11
    Likes Received:
    0
    Yes I have a working microsd card and its working. I don't turn on the copter until I have the RC on, extender on, and connected to my iPhone. Then I start the copter and open the app to connect everything. fyi
     
  11. eckoner

    Joined:
    Jul 12, 2013
    Messages:
    360
    Likes Received:
    9

    If you have the QR code from your box you can just reset the firmware and re bind

    I was having the same issue and tried a reset but then realized I needed the QR code to complete the pairing and I just happened to toss the box and I sent a message to DJI regarding this and it's been a week and I have not even gotten an automated response saying we got your note
     
  12. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    I still can't connect to mine with any consitency. Sometimes its 5 minutes of waiting until the network shows up on my phone....sometimes its 40 minutes. EXTREMELY frustrating!!!!!!!!
     
  13. joejoda

    Joined:
    Dec 26, 2013
    Messages:
    11
    Likes Received:
    0
    I spoke with Dronefly, and they told me they think I have a bad extender. They want me to send it back and they will replace it. I am going to reset and rebind and see if that improves things. If not, off to replace it. Any other suggestions?
     
  14. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    Let me know if that fixes your problem. I may have to do the same thing. Thanks!
     
  15. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    I also sent a support request to DJI almost two weeks ago, and I haven't gotten a single reply (automated or otherwise).

    Very poor customer service!
     
  16. benski

    Joined:
    Dec 28, 2013
    Messages:
    43
    Likes Received:
    0
    Hi I just want to elaborate on this point

    "This is INCREDIBLY frustrating as it is a complete crapshoot every time I go out to try and fly whether I will be able to or not. The last two times that I got it to connect and flew it, I flew it about 200 feet away from me when it "Lost Connection" and flew itself home."

    I am also having an issue where I can't get any further than 80m which is about 250ft. I did a test where I turned off the range extender (as I believe the range extender is only to link the phone to the camera and has nothing to do with controlling the P2V) and anyway I still only reached 80 metres before it lost signal.

    I tried the remote controller in FCC and EC mode and this made no difference.

    I see you are also having range extender issues (not being able to connect to phantom wireless network) but this sounds like 2 issues one with the 5.8 network not giving any more range than 200 feet and also issue connecting to 2.4 network for camera to iphone.

    Does anyone know how to confirm the remote controller is working correctly? Can it be connected directly via usb to DJI Phantom assistant RC app or the DJI Phantom 2 assistant app to have firmware reset or upgraded?

    It is really annoying to see that the P2V can fly up to 500m and I am only getting 80m
     
  17. webbroi

    Joined:
    Jan 21, 2014
    Messages:
    7
    Likes Received:
    0
    I'm having the Same Issues. Brand new Jan 21. Purchased from Amazon directly from DJI.

    So far Troubleshooting Steps:

    1. Updated the Phantom 2 Vision FC200 Firmware v1.1.9 Firmware vis micro SD Card.

    Instructions in this doc.
    http://download.dji-innovations.com/dow ... tes_en.pdf

    2. Also Updated all the Firmware via the Mac : Phantom 2 Vision Assistant Software v1.08

    3. Power Cycled The Phantom, Extender, Controller and my Android Phone

    4. Also tried to connect to the camera without extender, but no wifi showed up
    5. Tried to reset the extender with instructions here:

    http://wiki.dji.com/en/index.php/Phanto ... e_Extender


    6. The light on the camera is Solid Green, even in Wifi mode. This link tells me wifi is off? and the light should be blinking?
    http://wiki.dji.com/en/index.php/Phanto ... the_Camera

    7. Oh yea tried a different micro sd card too.

    This is a very frustrating first experience for something marketed as out of the box ready.
     
  18. SaintKelley

    Joined:
    Dec 17, 2013
    Messages:
    10
    Likes Received:
    0
    I feel your pain! I am still having problems and noone will return my support request emails at DJI. Very poor customer service. To spend this much money and have nothing but problems is incredibly frustrating!!!!!!!
     
  19. webbroi

    Joined:
    Jan 21, 2014
    Messages:
    7
    Likes Received:
    0
    @saintkelly,

    Can you return it? There are a few other threads here, but it seems like everyone is clueless about this issue. And they are not all the same issue...but one common theme. The camera is the problem.
     
  20. Venom93corba

    Joined:
    Jan 3, 2014
    Messages:
    188
    Likes Received:
    0
    I just received my P2V a week ago and I'm still running the stock firmware (1.05). I leave for a trip in 2 days and I'm taking the P2V with me. There is NO WAY I am updating this thing. The updates have been sooo buggy lately. It flies fine the way it is, ha ha.

    Sent from my Galaxy Note 2