Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

[SOLVED] Runs away in GPS mode with new update (2.10/3.10)

Discussion in 'Phantom 1 Help' started by TickTock, May 10, 2013.

  1. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    [UPDATE: Turned out to be operator error - compass was installed on the wrong leg]

    I find GPS mode very difficult to fly - I am constantly fighting the craft. In Atti mode, it is a rock (unless the wind blows). However whenever I flip to switch to GPS, it banks. Not circular - just picks a direction and heads that way picking up speed unless I override with the stick control. Not always the same direction (so not a stick calibration issue - although I did try re-calibrating the TX).
    If I start in a hover in atti, then flip the switch to GPS it will hover for a few seconds, then slowly tilt one direction until it is going full tilt (literally). Almost seems like one of the feedback signals is inverted (when it detects motion north, it interprets that as south and compensates in the wrong direction). At one point, I waited too long to correct with the TX (wanted to see if it eventually changed direction) and I was unable to overpower the direction it wanted to go. I ended up having to ground it while it was still moving pretty fast as it was about to smash into my house and I didn't have time to flip back to atti.
    Prior to updating the firmware to 3.10, I never noticed this behavior (it was pretty solid - occasionally exhibiting a circular motion when in a light breeze). I don't dare try the RTH feature until this is resolved! Any suggestions?

    I guess I should mention I did do a full (long) IMU calibration, recalibrated the compass, recentered the TX, and reinstalled the firmware. Multiple times.
     
  2. pwright

    Joined:
    Feb 23, 2013
    Messages:
    282
    Likes Received:
    0
    Location:
    Las Cruces, NM
    Re: Runs away in GPS mode with new update (2.10/3.10)

    That's scary. I wonder if anyone else is seeing this.
     
  3. Gary39

    Joined:
    Apr 8, 2013
    Messages:
    129
    Likes Received:
    1
    Location:
    Groton,N.Y USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Yes, gps mode is not as good as it was in 2.02, if you get it going in a certain direction you have to input opposite stick to stop it and get it to hover correctly. This was not the case with 2.02.
     
  4. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Thanks. I guess I'm glad I'm not alone. Everyone else seemed to rave about the new release. If is isn't just one outlyer, there is hope for a fix.

    I have a request if anyone is willing. Could someone who has a well-behaved 2.10/3.10 Phantom (rock solid GPS hover) export their parameters on the tools menu and share it in a dropbox or somewhere? Maybe if I load a know good set and recal it will solve my problem.
     
  5. Capodrone

    Joined:
    Apr 10, 2013
    Messages:
    72
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)



    Im still using old firmware and I enjoy fantastic gps hover, I dont think settings will help you, Did you do advanced calibration then power down and up, did you calibrate TX, did you do compass calibration?

    IF answer is no on any one of those items try and do it. see if that helps... led status lights normal? no errors in naza right!?
     
  6. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Hey TickTock, i suggest 2 solutions:
    1) Do a Full Advanced Calibration, keeping away from any magnetic source.
    2) Download "Default Phantom Parameters" from DJI website unzip it and then do an IMPORT with Tools Menu.

    http://www.dji-innovations.com/download/phantom-downloads/
     
  7. Audaciter

    Joined:
    Mar 18, 2013
    Messages:
    724
    Likes Received:
    2
    Location:
    Sunnyvale, California, USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Mine did that the other day too, but I thought maybe it was just because the wind was pretty strong, and blowing that direction.

    It was pretty scary. :eek:
     
  8. freelanceshots

    Joined:
    Apr 21, 2013
    Messages:
    187
    Likes Received:
    3
    Location:
    Dallas, Texas
    Re: Runs away in GPS mode with new update (2.10/3.10)

    I was flying mine yesterday with the new update where I was flying under trees with the phantom flying at about 6 feet where I was walking behind it doing some video and then all the sudden I just lost control and it went off sideways. With the loss of control it cruised off into a bush which was better a tree truck or branches. I tried to correct but could not pull it back. I was in GPS mode the whole time. I thought it was very odd when it happened as it just started drifting pretty quickly like a big breeze of wind hit it but where I was there was little to no wind. Not really a fan of the new takeoff setup either as mine immediately cruses off to the right for a moment instead of straight up.
     
  9. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Thanks for the suggestion Jumanoc. Unfortunately it didn't help. :(
     
  10. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Let's try more...
    Are you using a Mac or a Windows PC ? If it is a Mac... get a PC (even 10 years old laptop will work).
    If it is a PC use another USB port for connection and also try by changing your USB extension wire.

    .... discarding wrong points...

    ... don't remember... did you do TX calibration ?
    ... may be you are in GPS but left upper stick is in HL or CL?

    Just keep us up to date for helping... :ugeek:
     
  11. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    So far I've attempted the following
    1) reinstalled update
    2) recalibrated the IMU (advanced)
    3) recalibrated the compass
    4) recalibrated the stick travel in the NAZAM Assistance
    5) recalibrated the stick travel in the transmitter
    6) swapped tops (GPS) and compass with a friends Phantom
    7) imported default settings
     
  12. Gary39

    Joined:
    Apr 8, 2013
    Messages:
    129
    Likes Received:
    1
    Location:
    Groton,N.Y USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Some more of djis handywork. I found a place to get 2.02 installer back, but can't seem to find the old firmware to download. dji was real quick to come up with 3.10 and leave us with no way back in case it failed, which in my opinion it has.I noticed the gps upgraded to another version, apparently the gps problem is there.I sure as hell didn't download any upgrade for gps, must be part of 3.10 firmware.
     
  13. Capodrone

    Joined:
    Apr 10, 2013
    Messages:
    72
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)


    :shock: :? :evil:
     
  14. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    I've had limited success connecting to 2.02 and forcing the download through the [back] door (click on "no updates" next to firmware, type "door", enter "test" for username and "125" for password). This installed firmware rev 3.00 for me. However, my phantom still hasn't returned to the previous state. The throttle is back to the old profile, but it still drifts in GPS mode and startup is still fast (I don't get the repeated six yellow flashes I used to get during warm-up). I am confused. Is 3.00 the revision we were running before the 3.10 update?
     
  15. Capodrone

    Joined:
    Apr 10, 2013
    Messages:
    72
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)


    1. Great job it works!
    2. I like the throttle that way.
    3. Is it windy ? You also have to recalibrate everything.
    4. Your not getting the flashes because your IMU is already warmed up.
    5. 3.0 was a beta some units were shipped with apparently. I love v3 and my gps mode is more than acceptable.
     
  16. Gary39

    Joined:
    Apr 8, 2013
    Messages:
    129
    Likes Received:
    1
    Location:
    Groton,N.Y USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Firmware 3.0 is the last version under history,capidrone, you have the original stuff, what version is your firmware ? And what is the version you have for gps ? Thanks
     
  17. Gary39

    Joined:
    Apr 8, 2013
    Messages:
    129
    Likes Received:
    1
    Location:
    Groton,N.Y USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    TickTock, I just checked on the discussion part of this forum where capidrone and I have been discussing this issue. He has still got original stuff, he says his firmware is 3,0 I hope someone from dji is monitoring this forum, maybe they can get their software engineers to check their crap out before they release it and let phantom owners find the bugs.,
     
  18. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Thanks. I am showing version 6.0.1.3 for the GPS Firmware and 6.1.1.2 [Edit: corrected h/w version] for the GPS hardware. I would be interested in knowing what version is the original. If 3.10 also updated the GPS but reverting the firmware back to 3.00 doesn't undo it, that would explain what I am seeing (original throttle but still have the GPS issue). I wonder if I could buy a replacement GPS which still has the old firmware...
     
  19. Gary39

    Joined:
    Apr 8, 2013
    Messages:
    129
    Likes Received:
    1
    Location:
    Groton,N.Y USA
    Re: Runs away in GPS mode with new update (2.10/3.10)

    Yes that version of gps wasn't there before I downloaded 3.10, they have kind of a screwy statement in their upgrade wording, somethng about gps signal strength, but when you read it, it leaves you wondering what they meant to say. Don't buy another gps, let them fix their problem, they have to learn to check out their crap before they release it.I don't think there was a gps version showing before we downloaded, maybe there was.The wording in their improvement statemet says " increased demand for gps signal strength " What does that mean, you just don't get satellites to increase signal strength. Try flying in att. mode until they get it fixed, it's not too bad even in wind if you keep your eyes on what it's doing, and don't let it get too far away.
     
  20. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Runs away in GPS mode with new update (2.10/3.10)

    OK. I found some information on the 3.00 revision in another forum

    http://www.rcgroups.com/forums/showthread.php?t=1875210

    If you scroll down you can see that the GPS firmware is 6.0.1.2 and the hardware is 6.1.1.1 for their 3.00 setup so it does appear I got a GPS update which was not reverted when I switched back to 3.00. I need to figure out how to get my GPS back to 6.0.1.2.