Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

sent back for repairs before 1st flight

Discussion in 'Phantom 2 Vision + Discussion' started by TXP2V+, Jan 5, 2015.

  1. TXP2V+

    Joined:
    Dec 21, 2014
    Messages:
    2
    Likes Received:
    0
    I got a Phantom2 Vision + for my birthday. Weather sucked here for 2 weeks so I never had a chance to fly it. I did take it out the box to update/calibrate. I noticed the camera was jerking and went down ok but really slow to come back up. I contacted the place it was purchased and was told to send a video of what it was doing. They said it was malfunctioning and it needed to be repaired or replaced. It's on a UPS truck scheduled to be delivered tomorrow. Wish they would just replace the drone. Never even flown the thing.
     
  2. Jpooner808

    Joined:
    Dec 16, 2014
    Messages:
    68
    Likes Received:
    15
    Location:
    Oahu
    Sounds like you didn't calibrate it correctly.

    Had the same symptoms when I first got it. You have to also calibrate the wheel using the RC System Assistant although it says "Users should use the Assistant Software of flight control system to calibrate X1 channel."
     
  3. MacCool

    Joined:
    Nov 23, 2014
    Messages:
    803
    Likes Received:
    199
    Location:
    midwest USA
    My Vision+ did that too. Started working normally after I calibrated the tilt wheel. Working great since. When you calibrated the sticks, did you also separately calibrate the wheel?
     
  4. srchadwi

    Joined:
    Oct 15, 2014
    Messages:
    63
    Likes Received:
    0
    Same here. Was jerky till I re calibrated it - bummer you sent it back.
     
  5. spudmachine

    Joined:
    Dec 15, 2014
    Messages:
    37
    Likes Received:
    0
    Same for me. It was working fine out of the box, but then I calibrated the controller sticks and I must have forgot to wiggle the gimble wheel (V3 controller). So after that first calibration it started moving jerkily using the gimble wheel, but the phone controls were still smooth, so I guessed it was calibration right away and did a recalibration. After that it was fine.
     
  6. MacCool

    Joined:
    Nov 23, 2014
    Messages:
    803
    Likes Received:
    199
    Location:
    midwest USA
    If I'd bought the machine from them, I'd be a little worried about the depth of their knowledge of these quadcopters.
     
  7. rwskinner

    Joined:
    Dec 5, 2014
    Messages:
    68
    Likes Received:
    0
    Location:
    South Texas
    Same here, plus when I switched from Phantom mode to Naza Mode, I had to perform the calibrations over again.
    Gimble was nice and smooth afterwards.
     
  8. JJM

    JJM

    Joined:
    Jan 3, 2015
    Messages:
    99
    Likes Received:
    0
    Yup, a simple calibration is all it needed...
     
  9. TXP2V+

    Joined:
    Dec 21, 2014
    Messages:
    2
    Likes Received:
    0
    Hope that's it.
    The guy emailed today and said he found a new "trick" that might fix this.