Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. tommyb888

    Joined:
    Apr 7, 2016
    Messages:
    42
    Likes Received:
    9
    I was flying the other day messing around with the active track trying to lock into cars, at some point I stopped and tried to fly the bird towards me and it wouldn't move. The altitude and yaw controls were working but no horizontal movement. I then tried to RTH and it rose to the set height but still didn't come towards me. I then turned off the rc and it immediately started to descend even though it was set to RTH on the rc lost signal...also I noticed it wasn't reading the height correctly because when it was at 50m and I turned off the rc it immediately read 35m....anybody know what happened? Here is my flight log..incident around 11 min mark Phantom 3 Log Viewer - PhantomHelp.com
     
  2. Ramphex

    Joined:
    Mar 19, 2016
    Messages:
    761
    Likes Received:
    239
    Location:
    Pennsylvania
    Please update to the latest firmware on RC and AC and report back if the issue still persists.
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,767
    Likes Received:
    5,521
    Location:
    US
    At the 12:10 mark in your flight log, is it possible that you accidentally chose the option to auto land from the left side of the DJI GO app?
     
  4. tommyb888

    Joined:
    Apr 7, 2016
    Messages:
    42
    Likes Received:
    9
    Nah I turned off the rc and it was supposed to RTH but instead started descending so I quickly turned it back on and the regained full functionality
     
  5. Phantom fool

    Joined:
    Feb 29, 2016
    Messages:
    131
    Likes Received:
    40
    How far away from you was the aircraft when you turned off the RC?
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,767
    Likes Received:
    5,521
    Location:
    US
    The log shows 75m.
     
  7. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,767
    Likes Received:
    5,521
    Location:
    US
    The flight mode changed to auto landing and then the signal was lost 12 seconds later. I'm assuming you turned off the RC at the point where your log shows the signal lost message. I don't know what else would trigger the auto landing mode. Very odd.