Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

PROBLEM connecting mobile to dji VISION camera

Discussion in 'Phantom 2 Vision Discussion' started by 1pirate, Nov 8, 2013.

  1. 1pirate

    Joined:
    Nov 8, 2013
    Messages:
    2
    Likes Received:
    0
    Hello !

    i received my DJI vision today and i went to try it !
    But there is a problem with the connection between the camera and the range extender.
    I mean, i can connect my mobile (iphone) with the range extender, but when i try to have an image or access to the SD card, it can NOT connect. Says "camera off" or something similar...
    I've reseted the range extender several times but nothing... tried with other mobile , nothing. I've unpluged a few times the cable from the camera... but nothing append...
    Than i realize that the light from the camera status indicator is always OFF ...
    What can i do ??? can you help me please.. ?
    i cant film and i cant take pictures...

    Thanks a lot !
    cheers
     
  2. vbluguitar

    Joined:
    Oct 23, 2013
    Messages:
    44
    Likes Received:
    0
    Not to be silly, but did you try the little switch on the back of the camera? It needs to be set to wifi.
     
  3. 1pirate

    Joined:
    Nov 8, 2013
    Messages:
    2
    Likes Received:
    0
    yes i try it .. a few times…
    i wish it was that… one side and the other.. now its all the to the right, but still no sign.
    no light in any place..

     
  4. AHill

    Joined:
    Oct 10, 2013
    Messages:
    227
    Likes Received:
    23
    Also not to be silly but is phantom powered on? The camera only gets power when Phantom is powered on, camera light will come on then.
     
  5. yali

    Joined:
    Nov 8, 2013
    Messages:
    148
    Likes Received:
    0

    I received my vision today too. but having the exactly the same problem as yours. Since it is always off, I do not know if it still can take pictures. Im afraid I have to return it the the seller on Monday. My whole weekend will be ruined by this problem!
     
  6. Studiowise

    Joined:
    Oct 22, 2013
    Messages:
    273
    Likes Received:
    0
    Location:
    Bristol U.K
    one more obvious one, is the power and video jack cable firmly seated properly into the back of the camera?
    i reseated mine
     
  7. MrBojangles

    Joined:
    Jun 14, 2013
    Messages:
    44
    Likes Received:
    0
    Did you remember to set your phone to the phantom wifi net..? If you don't you don't get a connection
     
  8. yali

    Joined:
    Nov 8, 2013
    Messages:
    148
    Likes Received:
    0
    I reset and reinsert the plug in the back of camera many times. no luck
     
  9. Randyfthompson

    Joined:
    Nov 13, 2013
    Messages:
    14
    Likes Received:
    0
    Try rebinding. Page 14 or so in the manual.