Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 not RTH at 20% in Naza mode

Discussion in 'General Discussion' started by VoicOfReason, Sep 22, 2014.

  1. VoicOfReason

    Joined:
    Aug 29, 2014
    Messages:
    489
    Likes Received:
    129
    My Phantom doesn't RTH at low battery when in Naza mode. Is this normal?
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,619
    Location:
    Palm Beach Co.- FL
    YES.

    Page 24 & 25 of the P2 manual (rev 1.1) states:

    The low battery capacity warning alerts users when the battery is close to depletion during flight. When it appears,
    users should promptly fly back and land to avoid accidental damage. The PHANTOM 2 has two levels of low battery
    capacity warning. The first appears when the battery has less than 30% power and the second appears when it has
    less than 15% power.

    (1) When battery power drops below 30% and LED indicator will blink red slowly.
    (2) At lower than 15% the LED indicator will blink red rapidly, the PHANTOM 2 will also begin to descend and
    land automatically
    . After it has landed, keep the throttle stick at its lowest point or execute CSC.
    (3) There is a hidden third low battery threshold in addition to the 1st and 2nd level warnings. This uses 10.65V
    as its threshold. Both this voltage threshold and the 2nd Level Low Battery Warning will trigger auto-landing.
    Altitude can be maintained if necessary by pushing up on the throttle stick.

    Personally I have never 'tested' it. ;)
     
  3. IrishSights

    Joined:
    Jan 14, 2014
    Messages:
    1,410
    Likes Received:
    37
    Location:
    Bangor, Northern Ireland, UK
    It also will not RTH if it has lost satellite connection as it has no way of knowing where it is or where the hompoint is. You didn't say what your flight environment was. You could be below a cliff, behind tall trees or buildings. All will block good satellite lock and cause a RTH failure.

    Sent from Samsung S4 via Tapatalk
     
  4. locoworks

    Joined:
    Jul 4, 2014
    Messages:
    471
    Likes Received:
    10

    is the low battery RTH function activated in settings?
     
  5. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,619
    Location:
    Palm Beach Co.- FL
    I have not seen the option in the Assistant s/w.
     
  6. BWJ

    BWJ

    Joined:
    Aug 19, 2014
    Messages:
    144
    Likes Received:
    0
    Location:
    Denmark
    The option in Assistant 3.2 is under "advanced" - "battery" - "battery level warning threshold" then check go-home.
     
  7. sijbren

    Joined:
    May 26, 2014
    Messages:
    48
    Likes Received:
    1
    Location:
    The Netherlands
    You need to have the latest FW on your Phantom (v3.06)
     

    Attached Files:

  8. justin00

    Joined:
    Sep 19, 2014
    Messages:
    1,143
    Likes Received:
    25
    Location:
    Australia
    What settings are in "gimbal" tab if you don't mind me asking ?
    I have P2V+ and running 3.2 assistant and don't have that tab...
     
  9. HarryT

    Joined:
    Aug 4, 2014
    Messages:
    622
    Likes Received:
    0
    Location:
    Warrington, UK
    It has settings that control the range of motion, and speed of motion, of the Zenmuse gimbal on a P2.
     
  10. sijbren

    Joined:
    May 26, 2014
    Messages:
    48
    Likes Received:
    1
    Location:
    The Netherlands
     

    Attached Files:

  11. BWJ

    BWJ

    Joined:
    Aug 19, 2014
    Messages:
    144
    Likes Received:
    0
    Location:
    Denmark
    Gimbal Setting

    Settings

    "Tilt Control Gain" changes the movement speed of the gimbal. The higher the value the quicker the gimbal translates controller input.
    Adjust "Horizontal Limit" and "Vertical Limit" to change the gimbal’s tilt endpoints. Angle limits are shown below:

    If FPV mode is checked, the gimbal will roll with the aircraft and incur horizon tilt. If FPV mode is unchecked, the gimbal will not roll and try to maintain a level horizon.