Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P disconnects from app frequently

Discussion in 'Pro/Adv Discussion' started by Skipholiday, Oct 7, 2015.

  1. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    It doesn't matter if using the pilot app or the Litchi app it my P3P will disconnect.
    Sometimes I can get a few flights in before it crashes.
    (I always have control with the controller)
    anyway to check the log file and see what it could be?
    I tried reinstalling the newest firmware.
    Once it starts happening Im done. no matter what I do it will continue with the disconnects.
    Only way I can get it to work ok for a while is to wait with everything off and restart.

    Any assistance would be appreciated

    Thanks

    Terry
     
    skyhighdiver likes this.
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    Try another USB cable, You most likely have a flaky USB cable.
     
    sharper4 and Skipholiday like this.
  3. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    I have the same issue. Spent the first 5 minutes that trying to make it work.. Really dislike it
     
    Skipholiday likes this.
  4. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    I will try another cable this evening. thank you
     
  5. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,211
    Likes Received:
    907
    Location:
    Indy, USA
    Is it just going black and white, and connecting again? Or is it rebooting your device?
     
  6. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    It says Disconnected at the top in red
     
  7. Dirby

    Joined:
    Mar 14, 2014
    Messages:
    810
    Likes Received:
    128
    Location:
    Dothan Al
    mine did the same thing Disconect in red.
    than i up loaded the app before this last one.
    everything works fine now no Disconects.
     
  8. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    Mine has been doing this for a month or more. I've used pilot all and Litchi. I've tried reflashing the firmware. I will try another usb cable this evening.
     
  9. SouthernPhantom

    Joined:
    Jun 10, 2015
    Messages:
    315
    Likes Received:
    122
    I agree: cable. I had the same issue in the spring with my P3P and Samsung S5 phone. That phone has a non-standard USB port, which oddly accepts regular cables in part of the port. The DJI cable was simply loose. So I got a Belkin cable with the large S5 male end, providing a snug fit -- and the disconnects stopped!
     
  10. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    What kind of tablet?
     
  11. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,211
    Likes Received:
    907
    Location:
    Indy, USA
    The good thing is, you are not the only person that has this problem. The bad thing is, it could be one of many possible causes. The first thing I would try without the motors on, it to start record on video and move the cable around. Then go to each connector and move the plug itself around. Then stop record and power down everything, remove card and transfer video pr watch playback right from the card. If you see any disturbance during playback, or if did manage a disconnect then you know. After this I would repeat the same type of process on the gimbal.
     
    bobmyers and Skipholiday like this.
  12. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    Nexus 7 2013 v2.. I use the same tablet with my other Phantoms without issue.I also use Litchi and no issues
     
  13. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Try re-linking the controller... I had some disconnect issues and doing this seemed to help. I'll admit, I don't know what the reason would be for it working... But I have not had the problem since.
     
  14. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    The controller stays connected its the display
     
  15. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Oh so it's a lost signal vs. a disconnected... Those are two different things
     
  16. Skipholiday

    Joined:
    Jan 24, 2014
    Messages:
    659
    Likes Received:
    54
    Location:
    Anchorage Alaska
    Notification at top center of display says "DISCONNECTED" in bright RED
     
  17. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Ok then try re-linking.... I'm telling you I had the same exact problem and doing the re link procedure made it go away. I realize your cable is still connected... Just give it a try... It can't hurt
     
    Skipholiday likes this.
  18. DrLovecat

    Joined:
    Jul 6, 2015
    Messages:
    4
    Likes Received:
    1
    I had the same Issue while using the Pilot App with my Galaxy S5. I started putting my phone on "airplane mode" before flights thinking that my phone was being interrupted when other apps were trying to receive background information. It did seem to fix the problem for me as it hasn't happened since i started doing that. I don't ever use tablets though so I'm not sure if there is an equivalent fix.
     
    Skipholiday likes this.
  19. seek e

    Joined:
    Jun 3, 2015
    Messages:
    51
    Likes Received:
    6
    I had my first crash the other day because my cable did the same thing at the end of a flight. Screen went black and disconnected until a guy picked up my phantom and then wanted me to pay him to give it back. I have since thrown this cable away and repairs are costing me about 200$. Just marking it up as my bad. The cord was pretty new and I do hope it does not happen again. But I can't blame hardware or software. DJI IS AMAZING. I love the phantom hope one day can have an Inspire. Thanks customer service and the repair shop for always helping out and doing what they do. CHEERS.
     
  20. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    Can you share a link?