Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

L60P Limefuel 3.19 error

Discussion in 'Phantom 2 Vision + Help' started by UgashikBob, Sep 1, 2015.

  1. UgashikBob

    Joined:
    Aug 23, 2014
    Messages:
    143
    Likes Received:
    12
    Location:
    Ugashik Lakes Alaska USA
    My Limefuel L60P works with a P2V+ V2 @ 3.12. It does not work with a NIB P2V+ V3 @ 3.14. Will the L60P work on the new V3 if I back down to 3.12 or are there other options?
     
    #1 UgashikBob, Sep 1, 2015
    Last edited: Sep 11, 2015
  2. UgashikBob

    Joined:
    Aug 23, 2014
    Messages:
    143
    Likes Received:
    12
    Location:
    Ugashik Lakes Alaska USA
    Anyone have experience with a Limefuel L60P and firmware level 3.1.4?
     
    #2 UgashikBob, Sep 4, 2015
    Last edited: Sep 11, 2015
  3. kirk2579

    Joined:
    Jan 13, 2015
    Messages:
    1,334
    Likes Received:
    261
    Location:
    Girard. ohio

    sorry, I wish I could help. I have 2 L60p batteries myself but I kept my P2v1 at 3.08 and the plus at 3.12.

    heard 2 many battery issues etc. after 3.14 hit so I am sitting on current firmware for a while.
     
  4. UgashikBob

    Joined:
    Aug 23, 2014
    Messages:
    143
    Likes Received:
    12
    Location:
    Ugashik Lakes Alaska USA
    Kirk:
    Thanks for the reply. I wish I had received mine at something less than 3.1.4 also. I contacted LImefuel about the issue but no reply. I finally received a reply from Limefuel with a link to there blog which contained no references to a L60 and said all testing would be documented on that blog. This tells me nothing has been done to date and if and where there are options it will probably be like yours to stay at a down level firmware or return. Not impressed.
     
    #4 UgashikBob, Sep 4, 2015
    Last edited: Sep 11, 2015
  5. UgashikBob

    Joined:
    Aug 23, 2014
    Messages:
    143
    Likes Received:
    12
    Location:
    Ugashik Lakes Alaska USA
    Just edited prior posts to reflect my current mc firmware leve of 3.1.4. My apologies for the confusion.
     
  6. UgashikBob

    Joined:
    Aug 23, 2014
    Messages:
    143
    Likes Received:
    12
    Location:
    Ugashik Lakes Alaska USA
    Just received the following message from Limefuel:
    We apologize that the unit is not working for you. Can you try power cycling the DJI to see it will get rid of the error message?

    - Install L60P/L54P battery and power up DJI as normal.
    - If you receive error message, Power down DJI and remove battery.
    - Wait 30 seconds, and re-install.
    - Power up DJI as normal

    You may need to try this one or two times but once the “handshake” between the battery and your DJI is established, you should be good to go. Let us know if that doesn’t work and we can try to further troubleshoot.

    Thank you,

    Team Limefuel

    I tried the above procedure and the invalid battery message went away on the 3 rd attempt. Attaching my current firmware and battery status screen grabs: Phantom #2 Battery info 09112015.JPG Phantom #2 firmware levels 091115.JPG
     
    kirk2579 likes this.