Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help with Litchi

Discussion in 'Pro/Adv Discussion' started by Squirrelcop, Sep 14, 2015.

  1. Squirrelcop

    Joined:
    Apr 28, 2014
    Messages:
    21
    Likes Received:
    4
    I've been flying my P3P using iOS for several months now. I Decided to switch and try Litchi out. I bought a 2nd gen Nexus 7 and got all the software and everything updated purchased etc but cannot for the life of me figure out how to get it to connect.

    I very familiar with iOS and know nothing about android.

    In the litchi help files it says I must clear the defaults so the RC doesn't recognize the DJI Go app. Can't figure out how to do this..

    I plug my iPad back in and everything works fine....I plug the nexus 7 in and zero connection....

    I'd appreciate a little step by step if someone has a minute

    Thanks
     
  2. louforgiveno

    Joined:
    Jan 16, 2015
    Messages:
    644
    Likes Received:
    251
    On android go to settings then near bottom of list find default applications hit that find go app and press clear. You should then get the prompt when you start the controller
     
  3. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
    To add to louforgiveno's comments, once you have cleared the defaults, everytime you open either the DJI Go app or Litchi, it should ask you for default app, make sure you chose "ONLY ONCE" everytime, otherwise you will need to clear the default app again.
     
  4. louforgiveno

    Joined:
    Jan 16, 2015
    Messages:
    644
    Likes Received:
    251
  5. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    On android Samsung note 4 Lolpop, its a little different (fragmentation between manufacturers vs firmwares vs carriers etc). This may help others in the future.
    Settings (COG) > Application manager (downloaded tab) > look for DJI GO > scroll to Launch by Default and press "CLEAR DEFAULT".
    And as mentioned above, when prompted, press "JUST ONCE" when you plug the USB cable in and this will allow you to choose the app you decide to fly with.
     
  6. Squirrelcop

    Joined:
    Apr 28, 2014
    Messages:
    21
    Likes Received:
    4
    Thanks for the help but my dumb *** till can't figure it out...... I'm running a Nexus 7 w/Android 5.1.1

    I have installed both DJI GO and Litchi on it. I get no connection to the quad no matter which app I try to run. When I plug my iPad back in, everything connects and works fine.

    When I check all the app defaults they appear to be cleared out, but nothing. Neither app even asks me if I want to make them the default app,when I open them.

    Any other ideas I might try?

    ImageUploadedByPhantomPilots - DJI Phantom Forum1442336252.440223.jpg

    ImageUploadedByPhantomPilots - DJI Phantom Forum1442336125.991026.jpg ImageUploadedByPhantomPilots - DJI Phantom Forum1442336162.846724.jpg ImageUploadedByPhantomPilots - DJI Phantom Forum1442336203.353643.jpg ImageUploadedByPhantomPilots - DJI Phantom Forum1442336231.030201.jpg
     
  7. samivu

    Joined:
    Aug 17, 2015
    Messages:
    6
    Likes Received:
    3
    Location:
    Finland
    Did you try click that "disconnected" text?
     
  8. Squirrelcop

    Joined:
    Apr 28, 2014
    Messages:
    21
    Likes Received:
    4
    Yes...its cycles and say connecting for a few seconds then reverts to this. The DJI app doesn't connect either....only the iPad connects immediately and works with the DJI GO app when I plug it in.... Is the controller/transmitter somehow only linked to my iPad and needs to be reset somehow to recognize the Nexus 7?
     
  9. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
    Have you tried another micro USB cable? That was my problem.

    Sent from my Nexus 5 using Tapatalk
     
  10. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
    Also did you put it in the debugging mode

    Sent from my Nexus 5 using Tapatalk
     
  11. samivu

    Joined:
    Aug 17, 2015
    Messages:
    6
    Likes Received:
    3
    Location:
    Finland
  12. Squirrelcop

    Joined:
    Apr 28, 2014
    Messages:
    21
    Likes Received:
    4
    It appears to have been the cord.... I tried 3 different cords and the final one worked. Thanks everyone for the help!!
     
    JBG likes this.
  13. skyzalimit

    Joined:
    Jul 11, 2015
    Messages:
    36
    Likes Received:
    5
    Location:
    Near Charleston, SC
    I just downloaded litchi yesterday, and I had read that the first time you use it, you need to be connected to the plane and also a good WiFi connection, so it can register with the dji servers. I have done that, I'm sitting in my living room, wasted 1/3 of a drone
    battery so far, trying to figure out how to get it to connect. I keep getting the error message that the "app cannot connect to the internet to verify app.". But I am connected to my home router,I can access the internet with my browser or any other app, and this is how I first " initialized" my drone when I first got it, so I could even start the motors. I have figured out the USB issue that others seem to o have, so what's up? How can I get it to connect to the internet?! (I'm using the same tablet to write this, otherwise I wouldn't be running any other apps at the same time.)
    Any help would be appreciated. I was hoping to use litchi tomorrow, I have to be somewhere 150 miles away at 07:00 and I plan to use the drone, litchi or not.
    Thanks....
     
  14. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    it may be related to DJI's verification servers.. they are sometimes down
     
  15. halfpipe

    Joined:
    May 14, 2013
    Messages:
    126
    Likes Received:
    6
    Location:
    Atlantic Coast Canada
    I am doing something similar. I left the dji app on the ipad and bought a used nexus 7 2nd gen however only put the litchi app on the nexus not the dji go and when I lit everything up in the house with wifi present, the litchi ap connected to the aircraft thru the rc lickety-split. No decesisions needed from the rc because only the litchi was on the android
    I figure I will leave it that way but maybey use the hotspot feature on the cellular ipad so the nexus can get maps insitu
     
  16. skyzalimit

    Joined:
    Jul 11, 2015
    Messages:
    36
    Likes Received:
    5
    Location:
    Near Charleston, SC
    Great. Thanks for the info, I'll try again today. Well, the event is over and I was able to accomplish "orbit" without the Litchi software, just using my practiced piloting skills. What I really want the Litchi for mostly is the waypoint missions.
     
  17. saltire

    Joined:
    Jan 24, 2014
    Messages:
    241
    Likes Received:
    6
    Did you get this sorted? i have the same issues planned a small waypoint flight and went outside and the app came up with the same message as you"app cannot connect to the internet to verify app.". ( .This is no good if you are in a no wi-fi zone ,
     
  18. phuocsandiego

    Joined:
    May 3, 2015
    Messages:
    151
    Likes Received:
    65
    Location:
    San Diego, CA
    This response is a bit late but I'm hoping it'll help others sort through connection problems when using Litchi. I'm using the Google Nexus 9 and various tablets will have a slightly different way of changing what your default is for the P3 Remote Controller when you hook it up via the USB cable. You can either choose "Just Once" or "Always" depending on what you want to do and if you know how to go back... all this is further up the thread if you'd like to find out.

    Here's my fool-proof way of getting connected to your P3P/P3A using Litchi. I found out by accident that it has to do with the order of how you connect:

    1. Turn on your remote control WITHOUT having the tablet connected by the USB cable. Just leave the USB cable connected to the remote control but disconnected from your table. Your tablet should be in the holder but not plugged in.
    2. Turn on your P3P/P3A. If the Phantom is already RC linked to the remote, they'll connect themselves without needing the tablet.
    3. After just a few seconds, connect the USB cable to your tablet. It should then either start Litchi automatically (if you selected "Always" during one of the previous sessions), otherwise it'll ask you which app you want to use to fly. If you have it so that you select the app every time, then select the app you want to use and it'll open and you'll be connected to the app.

    I've found that following these steps will ensure an error free session. I've ran into this many times where I had everything plugged together and ended up killing the Litchi app, restarting the Litchi app, touching that red "Disconnected" button, etc. many times to no avail. It was by accident I found this order but now I never run into that problem. Good luck!
     
  19. n6vmo

    Joined:
    Feb 26, 2015
    Messages:
    484
    Likes Received:
    156
    Location:
    Lompoc, CA.
    I went to fly today and my Samsung Tab 4 kept giving me a 'Unfortunately, Litchi has stopped' message and would exit before connecting to the aircraft. I have had my share of Litchi disconnects before, but this was over the top. Luckily I had my Samsung phone to make the flights.

    I have been wanting to restore the Tab 4 to factory defaults, so I did this after my flights, with the hope it would clear up this issue. Installed Litchi 2.4.0 and I get the same 'Unfortunately, Litchi has stopped' message before I can select the type of aircraft. Very frustrating. Anyone have any ideas why all of a sudden my Tab 4 won't run Litchi, even after a factory reset?
     
  20. skyzalimit

    Joined:
    Jul 11, 2015
    Messages:
    36
    Likes Received:
    5
    Location:
    Near Charleston, SC
    It has been a while since I downloaded (and paid for) Litchi to use on my Nexus 9 tablet with my Phantom 3 Pro. I have tried all the suggestions everyone has made, but still, even in my living room attached to my home LAN, with everything turned on & connected, I get the same error message, "unable to access Internet to verify software." I'm wondering if anyone can think of anything I haven't tried? I always check the "only once" box when the window pops up asking which app to allow USB access (after selecting Litchi), I have USB debugging turned on, and I've tried it with the GO app on and off (but always after I have connected once south the GO app to make sure everything is warmed up & connected properly). So, I still haven't been able to actually use the Litchi app. Does anyone have anything they can offer? Thanks in advance....