Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help... New Phantom crashed and solid red LED

Discussion in 'Phantom 2 Vision Help' started by jrspero, Jul 13, 2014.

  1. jrspero

    Joined:
    Jul 13, 2014
    Messages:
    2
    Likes Received:
    0
    Hello guys,

    I am new to the Phantom 2 Vision and have flown it a couple days. today i was flying it and hit some tree limbs. It crashed to the ground and the only thing that appeared to be damaged was the blades. I replaced them and attempted to fly. If i just turn the phantom on i get the normal startup cycle of LED then blinking yellow in the rear. as soon as i turn the transmitter on i get solid red in the rear. I have tried to calibrate the compass because when i hook it to the DJI assistant it says compass ERROR but i am unable to get it to go into calibration mode.

    Also in the assistant the compass is showing all 0's.

    Can anyone please help a new DJI owner out PLEASE!!!!!!

    Thanks in advance.
     
  2. mb_guy

    Joined:
    May 5, 2014
    Messages:
    91
    Likes Received:
    0
    Location:
    Winnipeg, MB. Canada
    I believe that is a system error, you are correct in checking in the assistant software. If there is an error number (ie:27 or something like that) there is a list of those. Just Google for it as I don't have it handy right now. Likely going to be a parts replacement.
    Here are the error codes
    http://www.djiguys.com/Forum/viewtopic.php?f=4&t=38