Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Fatshark battery & phantom charger.

Discussion in 'Phantom 1 Help' started by Suva, Nov 7, 2013.

  1. Suva

    Joined:
    Nov 7, 2013
    Messages:
    2
    Likes Received:
    0
    I recently bought Fatshark dominator set, but I have problem trying to charge the battery that comes with it.

    When I plug it in to the phantom charger, only the 2S light blinks, slowly once in 3 - 4 seconds. Kept it like that for few hours, nothing seemed to change. The other lights stay dim.

    I tried plugging it into the goggles, everything seems to work, and there seems to be enough charge in the battery, not sure how much.

    I tried measuring the voltage with multimeter while plugged into goggles. One cell gives 3.81V other one 3.84V.

    Any ideas what could be the problem?
     
  2. hurseyc

    Joined:
    Sep 20, 2013
    Messages:
    43
    Likes Received:
    0
    Are you plugging in both cables? With mine I have to use a supplied adapter for the main power then also plug in the balance connector.
     
  3. Suva

    Joined:
    Nov 7, 2013
    Messages:
    2
    Likes Received:
    0
    Yes, both cables are connected. Balancer to 2S port, and the barrel connector through supplied banana plugs to the charger.

    Polarities are also correct, I doublechecked them with multimeter.
     
  4. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    the Phantom charger is about as cheap as they come, and seem to have troubles charging certain batteries if they are unusually low on mah to begin with.

    There's not much of a fix if you plugged everything in properly, set it to Lipo and 1A and the battery doesn't appear to charge.

    But your best bet is to look into getting a more robust "real" Lipo charger that's much more capable of charging, storage charging, etc., with a digital readout.
    you'll be much better in the long run
     
  5. Alardt

    Joined:
    Dec 5, 2013
    Messages:
    3
    Likes Received:
    1
    Mine (Phantom Charger) was doing the same thing and the Lipo switch had been bumped. I moved it to the left (Lipo) and it (the Fatshark Battery) started charging normally.
     
  6. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    ^This

    Cheap and has been working great for me: http://www.hobbyking.com/hobbyking/stor ... duct=18066
     
  7. moveease

    Joined:
    Jan 8, 2014
    Messages:
    15
    Likes Received:
    0
    Location:
    San Francisco, Ca
    I don't really feel like buying a proper charger for my fatshark battery, do you guys think this setup will work ? I cut the end off of this charger I found in the trash, it says " 5v - 1Amp" the fatshark battery is "7.4v - .76Amp" close enough right?
     

    Attached Files: