Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI-Go Connection Problems

Discussion in 'Standard/4k Discussion' started by Ottavio, Jan 1, 2016.

  1. Ottavio

    Joined:
    May 17, 2014
    Messages:
    2
    Likes Received:
    0
    Location:
    Houston, Texas
    New to the site! I can not get my video to sync to my RC. I have followed every suggestion on this site and all I get is "How-To-Connect" page. I have been communicating with DJI both through emails to support and the support chat, but responses are sporatic. I have upgraded to 1.6, tried different devices, changed the cable and performed the C1/C2/Shutter button restart to no avail. I am using a iPad Air2 with the latest iOS. Any suggestions?

    Thanks in advance for the help!
     
  2. jingleimages

    Joined:
    Dec 29, 2015
    Messages:
    7
    Likes Received:
    0

    Try reinstall the app.



    Sent from my iPhone using PhantomPilots mobile app
     
  3. Ottavio

    Joined:
    May 17, 2014
    Messages:
    2
    Likes Received:
    0
    Location:
    Houston, Texas
    Thanks for the advice... But it did not help.
     
  4. Steve Hoggard

    Joined:
    Apr 21, 2016
    Messages:
    18
    Likes Received:
    0
    I am having the same issue.. Everything was fine, took video on a camp out, packed everything up, pulled the drone out a few days later and the app will not connect to the camera. I have a green light on the cam, the gimbal responds to the controller and phone recognizes the usb connection with the RC... Still the app will not connect to the camera?????
     
  5. Glen B

    Joined:
    Mar 10, 2016
    Messages:
    31
    Likes Received:
    4
    Do you also have litchi installed? If so, you have to force close both apps and only reopen the one you want to use. I use Shutapp (android).

    Also, noticed sometimes I have to toggle between still shots and video to refresh the video.