Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Did the wrong steps when updating P3A

Discussion in 'General Discussion' started by ImJim, Aug 8, 2016.

  1. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Hey,

    My RC is completely screwing up since I tried to update it to v 1.9 three weeks ago. (I'm sure it's because of that) I can't connect my iPhone to the RC, no connection between the RC and the iPhone. I tried everything: backed up the phone and restored it via iTunes twice, deleted/reinstalled the app, tried other phones, changed cables.. But there's one step I probably didn't do corretly.. updating the drone to the latest version.

    Indeed, I had ver. 1.2.8 since one year now. 3 weeks ago, I directly updated to the latest version without updating to ver 1.3.2 first. (apparently, that's what you have to do, check msinger's thread).. When I realized that, I tried to downgrade to 1.3.2, then update to 1.9 again. (that sounds stupid I know) But it seems impossible, as v. 1.3.2 is too old to downgrade to. What can I do now? The fact I updated without doing things correctly 3weeks ago probably f*cked my drone. Also, I don't even know if my RC version is identical to the drone's version. I can't control the rotors with the RC, that's weird... I remember being able to start the motors last year, even without DJI Go. Though I CAN control the camera with the RC.

    PS: here's the TXT file after v. 1.3.2 downgrade attempt :

    ========== 2016.08.03 14:03:57 =====================
    Packet: P3S_FW_V01.03.0020.bin
    Result: Abort.
    The current firmware does not support downgrade. Use a different version of firmware to downgrade the target version.


    I'm lost! Please help!! :(
    Thanks in advance..
     
  2. rockydog

    Joined:
    May 25, 2015
    Messages:
    884
    Likes Received:
    251
    Location:
    London UK
    The 1.9 firmware is for the P3, not for the RC (controller). The latest RC version is 1.6, and if you're running an old version you need to update the RC to 1.3.2 using firmware on a card via the usb port...after that you will be able to update the RC to 1.6 via the GO app.
     
  3. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Ok thanks a lot! Now how do I update to 1.6 for the rc? Knowing that :

    1) I don't even have a working micro SD reader to plug in the RC

    2) I can't update via DJI Go, as it won't connect to my iPhone!

    I've read that I could update the RC by plugging it to the P3 and installing it that way. Does this mean that I have to format my SD card, put the v. 1.6 of the RC firmware in it, and update like that?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    ImJim, I see you mentioned my thread above, so I'm assuming you've read it. The firmware installation instructions are described in great detail there. Can you tell us which step you're stuck at?
     
  5. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Yes, I'd like to get the firmware for my RC. Both 1.3.2 and 1.6 .. as I'm supposed to first update to 1.3.2 and then to 1.6 (RC only). So I guess I have to put the v. 1.3.2 in my SD card, insert it in the bird with the RC plugged in, and update it this way.. But, will putting 1.3.2 version in the SD downgrade the drone's version?! And how to find ver. 1.6 ? I can't update through the DJI Go app... :( Thanks again msinger ..
     
  6. rockydog

    Joined:
    May 25, 2015
    Messages:
    884
    Likes Received:
    251
    Location:
    London UK
    If you haven't got a card reader, have you got a usb pen drive? If you have, you can copy the 1.3.2. file onto that and plug it in to the RC.
     
  7. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Yep, I have a pen drive. I'm going to update with this. When it's done, how to update to 1.6 then?
     
  8. rockydog

    Joined:
    May 25, 2015
    Messages:
    884
    Likes Received:
    251
    Location:
    London UK
    After you've installed 1.3.2 you update the RC via the GO app. If you're saying that you can't connect your RC to your phone at the moment I can only come up with 2 thoughts....1.Delete the app on your phone and re-install it. 2.Try a different cable to connect the RC to your phone.
     
  9. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Ok, tried to install v 1.3.2 with a usb pen reader, and nothing happened. It must be the USB pen not working, or .. the usb of the RC..
     
  10. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    No.

    You will only be able to upgrade to 1.6 via DJI GO after you install 1.3.2.
     
  11. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    Thanks again. I wasn't able to update to 1.2.3. I tried with my USB pen reader, and nothing happened: nothing to read in the SD card, no text file created. Then, I tried your method (updating with the sub cable, with the bird), and again, no results no blue led, no text file in the SD. I'm definitely lost.
     
  12. ImJim

    Joined:
    Jul 8, 2015
    Messages:
    184
    Likes Received:
    35
    There's one thing I'd like to add.. When I plug my iPhone cable inside the RC USB port, there's no "trust this device?" message and no connection "notification" (no vibration, no sound...) Suggesting the USB doesn't even recognize the device.