Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Defective P3A?

Discussion in 'Pro/Adv Discussion' started by tclark333, Feb 20, 2016.

  1. tclark333

    Joined:
    Jan 18, 2016
    Messages:
    36
    Likes Received:
    26
    I think I have a defective P3A, but I wanted to get some opinions before I went through the process of trying to return it. I've had it for a month and upgraded all firmware to the latest version the day I got it. I've tried as many things as I can think of - hoping it was because of something I was doing or how I was using it, but at this point it just seems like something isn't right.

    Here are some of the things I've experienced:
    • Video files are corrupt more than 50% of the time. This is my biggest issue. It's been happening since day one. No matter what kind of flight I do, I land it, stop the video recording, and turn everything off, and get an error when trying to play the video. I'm using the SD card that came with it, but I also tried another card and had the same issue. I use the djifix.exe program to fix what I really want to keep, but unfortunately most of those play in slow motion after the fix.
    • No signal in video mode with DJI Go app. One of the main reasons I use Litchi is because of all the issues I have with the DJI Go app. When I put the camera in video mode, my signal immediately goes out. I can control the drone, but I have no video signal. I can see things fine with it's in picture mode, just not video. I've tried multiple phones and tablets and I either have that problem, or the video feed is there but very choppy and delayed.
    • Remote beeps after a few minutes when drone is out of range. I use Litchi to fly auto missions, and after a few minutes of my drone being out of range, my remote starts beeping. It doesn't give any indication of what's going on, and the remote battery is charged, so I have no idea what it means. During my last mission, after beeping like that for a bit, it finally went from 'Signal Lost' to 'Disconnected'. My drone came back in RTH mode and I couldn't reconnect to it even after restarting the app, so I had to catch my drone.
    • Missions don't complete. Again, using Litchi, I've had lots of issues with long missions not completing successfully. Lots of times it comes back in RTH mode, and then I have corrupt video files. One time I still had full signal of the mission, but the mission just stopped and I had to take over to bring it back.
    • Lots of compass calibration errors. I continue to calibrate my compass, but during flights, I often see a red message stating there is a compass calibration error. I can't tell that this has caused any issues in flight, but it's definitely concerning.
    My brother has a P3P and hasn't had any of these issues. He uses an iPhone whereas I use all Android devices, but since I've tested things out on over four devices, it's hard to believe that Android is the issue. I wouldn't think that everyone using Android devices has had all of the issues I have. After all this time, and hating to think of having to send this back, I'm starting to think I need to before something goes wrong and I don't have anything to send back...
     
  2. shockwave199

    Joined:
    Dec 19, 2014
    Messages:
    1,067
    Likes Received:
    405
    My opinion, send it in. With all those issues you have nothing to lose and everything to gain. Don't fly or wait another day. Send it in.