Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

CSC does not start motors.

Discussion in 'Phantom 2 Vision + Discussion' started by JETP, May 19, 2014.

  1. JETP

    Joined:
    May 19, 2014
    Messages:
    3
    Likes Received:
    0
    Hello,

    I got the P2V+ and the motors did not start when I performed the CSC.

    I already did everything the manual says (read it completely 2 times) but it seems that the Phantom does not obey to the remote controller.
    Updated software and calibrated compass too.

    Green lights are OK flashing slowly and the camera works perfectly with my smartphone.

    Can any of you help me to find out why the motors did not start?

    Thank you in advance.

    JETP
     
  2. KG4MXV

    Joined:
    Mar 29, 2014
    Messages:
    198
    Likes Received:
    1
    Down load the assistant software and the driver software if you have a windows PC
    Install the software.
    connect the craft to your computer with the USB cable
    Take off the props.
    power everything up and start the assistant software and under the craft mixer type should be X type

    See if that is the issue.
     
  3. kgarrison

    Joined:
    May 5, 2014
    Messages:
    126
    Likes Received:
    0
    And calibrate the sticks
     
  4. phantomguy

    Joined:
    Mar 26, 2014
    Messages:
    349
    Likes Received:
    2
    Rebind the transmitter to your phantom
     
  5. denofr

    Joined:
    Apr 11, 2014
    Messages:
    131
    Likes Received:
    0
    This happened to me and the clue to what was wrong was that the light on the controller was yellow which when that is the case the motors wont turn on. If yours is the same then it may mean that you have not finished fully calibrating the compass.
     
  6. JETP

    Joined:
    May 19, 2014
    Messages:
    3
    Likes Received:
    0
    Hello,

    Thank you all for your kind help!
    I will follow your instructions.

    Have a great day!

    JETP
     
  7. erico

    Joined:
    Jan 19, 2014
    Messages:
    62
    Likes Received:
    0
    Location:
    Koh Samui Thailand... from Carrickfergus N Ireland
    I have had the same problem the last couple of days . I have a phantom 2 with h3 2d and go pro . I have been practising about 20 yards from my house in the same area with no problems before . Yesterday and today I have went out started up waited till I got the green lights and when I give the crc command I get two flashing red lights and motors won't start .? I have turned it off went back into house to check all ok then went out again and it worked . Yesterday I just took it as being a bad contact but the same thing happened again today . Tonight I checked again just outside and all worked ok . Can anyone throw some light on the problem ? It's just annoying me I am doing something wrong . I went back to the manual but I don't see any where about two flashing red lights when I try to start up the motors .

    Thanks


    Sent from my iPad using Tapatalk
     
  8. erico

    Joined:
    Jan 19, 2014
    Messages:
    62
    Likes Received:
    0
    Location:
    Koh Samui Thailand... from Carrickfergus N Ireland

    Sorted .. I had calibrated wrongly... feel a bit stupid when I turned the Phantom on its side I was then rotating it the wrong way .. but I will not make same mistake again :)
     
  9. JETP

    Joined:
    May 19, 2014
    Messages:
    3
    Likes Received:
    0
    Hello,

    Just want to let you know that he problem has been fixed. The controller did not had a full green led light when I tried to start the motors because it needed stick calibration. That was the problem. This aircraft is awesome!

    Thank you.

    JETP
     
  10. chimaera

    Joined:
    Aug 8, 2014
    Messages:
    1
    Likes Received:
    0
    Hi Everyone,

    In am having the same problem as the other guys in this forum and can't solve it.

    When I perform a CSC I get 3 red blinks and the rotors does not start. I have calibrated the controller and it still does not work.

    I have only ysed the Phantom 2 vision+ on 1 occation and I could fly without a problem. 10 minutes later when I rebooted the drone I got this issusue. After a few reboots it worked again...

    But now I can't get it up in the air.

    Hopefully you guys can help me and give me some advice.

    Best regards,

    Dan
     
  11. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Make sure the Transmitter Remote controller is in MODE 2 (left stick has yaw, right has direction).
    Make sure the compass has calibrated properly. Do it via the DJI app on your phone. It has clear instructions.
    Make sure the transmitter talks to your phantom. You can check in the Phantom assistance by moving the sticks around. Another method is to turn on your phantom first, it will blink yellow, then turn on your controller and it will blink green (depends on satellites too).