Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Charger problem

Discussion in 'General Discussion' started by wiggy, Jan 19, 2015.

  1. wiggy

    Joined:
    Dec 18, 2014
    Messages:
    6
    Likes Received:
    0
    My Phantom 2 Vision Plus charger was fine yesterday. I've plugged a flight battery in and the charger wont charge it. The LED on the charger flashes red. I've tried plugging batteries in switched on, switched off etc and it still flashes red..it hasn't between reversed polarity.

    Any ideas ???
     
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    No but flashing red is abnormal, it should be steady red or steady green.
    I'd get another, they aren't that pricey.
    I guess you tried it on another battery?
     
  3. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    In general I would always suspect the load as the problem initially - so try your charger with a different battery and try to work out whether it is the charger or the battery is at fault.

    Also connect your quad up to the Assistant software and see if you have any problem cells.

    If is looking like the battery and you dont have an obvious cell fault, you could also try to discharge the battery and then try charging it again.
     
  4. wiggy

    Joined:
    Dec 18, 2014
    Messages:
    6
    Likes Received:
    0
    Thanks for the replies. It's on all three batteries. Assistant says all the batteries have over 30% left in them. I've ordered a new charger and contacted the agent as its only 6 weeks old...and I want a 2nd charger anyway.
     
  5. len750

    Joined:
    Dec 10, 2013
    Messages:
    218
    Likes Received:
    14
    wiggy, has getting a new charger fixed your problem? I'm having the same issue.Only discharged the batteries 3 times! Bummer that this is happening on a new charger for me.
     
  6. J.James

    Joined:
    Apr 21, 2014
    Messages:
    1,882
    Likes Received:
    162
    Location:
    Upstate NY
    Do you have a volt meter of any kind to see if its putting out any voltage on the 2 blades You should be getting a tiny bit over 13 volts out. if not its the charger for sure. also if any load is on the charge the led should go green.


    Probablly not the best way to test if the charger is working but if you have no way to check it you could also check it like a 9v battery to your tongue to the 2 blades and if its working you will get a shock and the light will go green. :)
     
  7. rstekeur

    Joined:
    Jan 27, 2014
    Messages:
    233
    Likes Received:
    41
    Location:
    Ft Myers, Florida
    I don't think I would want to put 13v 5amps to my tongue. It would be DJI Viagra.
     
  8. J.James

    Joined:
    Apr 21, 2014
    Messages:
    1,882
    Likes Received:
    162
    Location:
    Upstate NY
    Ya it does have a tiny bit of bite to it. But nothing like what you can get off the battery pack. :lol: man they pack a punch.