Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Black Pearl 7" / Immersionrc 600mw - not getting display?

Discussion in 'Phantom 2 Discussion' started by mysticalice, Apr 10, 2014.

  1. mysticalice

    Joined:
    Feb 15, 2014
    Messages:
    73
    Likes Received:
    0
    Hi
    Just assembled my FPV setup this evening. Wanted to test everything first before I cleaned up the wiring. Connected the ImmersionRC to the mini iosd, then the mini iosd to the 'cam' port on the P2 (using a pre-made cable), then powered everything up. I'm definitely seeing the iosd mini display on the screen, but not clearly - it's like the screen is 'scrolling' - lots of static. Can't make out much.
    Black pearl 7" screen

    Any ideas?

    I tried this before and after updating the mini iosd firmware, and same problem
     

    Attached Files:

  2. mysticalice

    Joined:
    Feb 15, 2014
    Messages:
    73
    Likes Received:
    0
    Re: Black Pearl 7" / Immersionrc 600mw - not getting display

    Here's the screen:
     

    Attached Files:

  3. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Re: Black Pearl 7" / Immersionrc 600mw - not getting display

    Try changing between PAL/NTSC on the display? May have nothing to do with it but saw a similar problem the other day in a thread and this fixed it.
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Re: Black Pearl 7" / Immersionrc 600mw - not getting display

    +1 that would be my guess too
     
  5. mysticalice

    Joined:
    Feb 15, 2014
    Messages:
    73
    Likes Received:
    0
    Re: Black Pearl 7" / Immersionrc 600mw - not getting display

    Good advice!

    I actually tried changing NTSC to PAL and vice-versa, BUT I was too impatient - I didn't give it enough time for the video to adjust.

    For anyone searching for the same problem (scrolling video on immersionrc), you have to change the screen to NTSC and wait 5-7 seconds for it to auto-adjust.

    Thanks guys - works like a charm. Can't wait to put it all together and go fly it tomorrow evening :) :)