Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

ARDRONE FLIGHT PRO QUESTIONS for PHANTOM FC40 OSD

Discussion in 'Phantom FC40 Discussion' started by jetcobra, Feb 20, 2015.

  1. jetcobra

    Joined:
    Feb 18, 2015
    Messages:
    9
    Likes Received:
    0
    I got a FC40 for Christmas and have read the thread on the IIVI mod to add the OSD using ARDRONE 2.0 parts. So I now have a 2.0 chassis and have hooked it up to 12 volts and have it running - checked it on Freeflight and found the software was at 2.4.8 and the cameras worked, so I bought ARDRONE FLIGHT PRO and tried to connect it to the 2.0 electronics but I get a screen saying "Connecting to Drone...." and then on the bottom it says "Waiting for Drone navdata.." and it just sits there and keeps searching. Is this correct or should I be doing something else? Also if I tap the screen (I am using a Kindle Fire HDX) I get a screen that shows an OSD but the only things that work when I touch them are settings and the camera button that takes pictures - I get no camera display and cannot switch cameras. Also, there is no UI option in settings. Again am I doing something wrong?
     
  2. jetcobra

    Joined:
    Feb 18, 2015
    Messages:
    9
    Likes Received:
    0
    Well I figured out how to get everything going and I now have both cameras from the ARDRONE 2.0 working along with the OSD in ARDRONE FLIGHT PRO - I have ordered a Navistick to use for GPS and will have it in a week. The only remaining issue I have is that the ARDRONE FLIGHT PRO OSD shows the battery icon but always shows zero's. I have gone through all of the menus and have calibrated and reset the program but still get zero even though I am using a brand new battery that measures 12.5V. Anyone have any ideas about how to get the battery percentage showing?