Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Yellow light on controller

Discussion in 'Phantom 2 Vision + Discussion' started by SSR99, Dec 13, 2014.

  1. SSR99

    Joined:
    Oct 8, 2014
    Messages:
    39
    Likes Received:
    0
    I have updated and calibrated my new Vision2 and installed the lats firmware for the controller...I had a bit of a problem with the new wheel moving roughly, but recalibrated it is fine now..
    BUT NOW...I have a yellow lite on the controller, and can't start the motors. Do I need to rebind the controller and the Vision?

    Thanks everyone for all the help..
     
  2. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,219
    Likes Received:
    914
    Location:
    Indy, USA
  3. SSR99

    Joined:
    Oct 8, 2014
    Messages:
    39
    Likes Received:
    0
    Ok..tried that...not working.
    It tels me to power on the camera...uuuhhh how do I do that..doesnt turning on the vision do that\?

    Sorry guys, just really frustrated..I had it all good to go...then screwed around and I messed it up..

    ...any other ideas to help me ?
    Thanks
     
  4. sbjr0203

    Joined:
    Jul 23, 2014
    Messages:
    101
    Likes Received:
    2
    Location:
    Connecticut
    Make sure you've calibrated S1 & S2 also.
     
  5. SSR99

    Joined:
    Oct 8, 2014
    Messages:
    39
    Likes Received:
    0
    ive engaged naza abd all switches are correct..still when I turn on the controller...i get 4 green LEDs to show battery...but a solid yellow...
    Gawd...
     
  6. sbjr0203

    Joined:
    Jul 23, 2014
    Messages:
    101
    Likes Received:
    2
    Location:
    Connecticut
    In RC Assistant when you calibrate the RC did you do S1 & S2 also? Reason ask I had same issue, but when went back in calibrated those switches also and issue(s) resolved.
     
  7. SSR99

    Joined:
    Oct 8, 2014
    Messages:
    39
    Likes Received:
    0
    THANKS!! I tried that twice, but obviously I missed a step. Alls good, camera moves nice and smooth,initiated NAZA , installed the gimbal guard, off try my first flight...Thanks again to all the answers and ideas.


    **** glad I found this site