Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Well, this is disappointing

Discussion in 'Standard/4k Discussion' started by respibob, Jul 23, 2016.

  1. respibob

    Joined:
    Jul 13, 2016
    Messages:
    100
    Likes Received:
    29
    Location:
    Southern Indiana
    I got my new P3S today and was very excited. I had been watching a lot of videos and quickly went through updating the firmware and it said it was successful. But that is where it ends. I have the RC on and the Phantom. The front lights are solid red, the back are blinking rapidly yellow and not matter if I use my Note 5 or my tablet it says Signal Lost and that is where I am stuck. I have been searching on here but can't figure out how to fix this and DJI support is closed today. My app is 2.8.2 and my firmware is 1.6.80
    I guess I will have to wait till they open on Monday but I work nights that day and will have to sleep!
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,925
    Likes Received:
    5,574
    Location:
    US
    Try linking the remote controller -- like this:

     
    Digdat0, shanek and hexagon like this.
  3. respibob

    Joined:
    Jul 13, 2016
    Messages:
    100
    Likes Received:
    29
    Location:
    Southern Indiana
    That worked! How could I have missed that. Thank you!
     
    Digdat0 likes this.
  4. respibob

    Joined:
    Jul 13, 2016
    Messages:
    100
    Likes Received:
    29
    Location:
    Southern Indiana
    I felt like such a dork. I had watched all those videos and read stuff and still did something so stupid! Oh well, it is flying great and I am having fun!
     
    Storm likes this.