Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Waiting new P3P, which versions of GO app & firmware to chose.

Discussion in 'Pro/Adv Discussion' started by Muva Bee, Jan 25, 2016.

  1. Muva Bee

    Joined:
    Jan 3, 2016
    Messages:
    87
    Likes Received:
    44
    I red whole DJI GO app 2.5 geofence thread, and i'm big supporter of P3 jailbreak project.

    I returned my P3A because camera out of focus and now waiting on P3P.
    Lets say i get device with firmware 1.3 version.

    You think if i install DJI GO pilot app 2.4.3 keep 1.3FW i'll be "geo free".
    I would say not, as some guys reported that even oder versions of app fetched NFZ's when fetching maps.

    Doing black magic with FW/App version makes no sense to me. I think best is to get latest and accept NFZ's until someone manages to bypass that sh**.

    Yeah?
     
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    You can go up to 1.6 firmware and that gives you the improved battery management in cold conditions.
    App 2.4.3 is the last one before suspicious changes started.
    I would download that app version now, but leave the firmware as is for a while, but download and save 1.6 in case it disappears suddenly.
    It will nag about firmware updates but no need to do it.
    If you install 1.6 you'd be best to update the controller too (via the app)
     
  3. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    660
    Location:
    Warrenpoint, Ireland
    Depends where you live. Where I am, there aren't any NFZs within about 30 miles and even then, they're airports, military bases and a prison or two. So NFZs aren't a problem for me. I always update to the latest firmware / software straight away. Just my thing.
     
  4. Muva Bee

    Joined:
    Jan 3, 2016
    Messages:
    87
    Likes Received:
    44
    I like updating to latest firmware / software too. I red that from 1.4 -> 1.6 device speed get lowered a bit. Also 1.6 battery fix includes "propulsion limit" if too cold to avoid battery shutdown, etc i aware of this. As there is no currently NFZ issues in my area i'll do small research.

    I'll check & report existence of NFZ-s with stock FW (i expect it to be 1.3) and APP 2.4.3(i have that one currently)

    If i get NFZ-s, i'll update to latest just because of funny sounds device produce when completed :)
     
  5. Jtrjr

    Joined:
    Mar 28, 2015
    Messages:
    444
    Likes Received:
    277
    Location:
    South Dakota
    Muva,

    Okay, I'll be the bad guy! If it's me, I'd go 1.4 on the bird (advanced flight modes), 1.3 on the RC and try to get to 2.4-2.4.1 maybe 2.4.3 on the DJI Go app (Android? use for settings only). Find the older version of Litchi that works with that FW and fly with it. That's the P3Pro perfect world to me.

    I naively did the update to 1.5 on my bird and RC and I'm kicking myself in the @ss for doing it! I backed the bird down to 1.4 but haven't done the RC yet. On my iOS device, I didn't have auto-updates off so DJI Go already updated to 2.5.1. I usually don't use the iOS stuff and my droid devices are still on 2.4.3 so I'm hoping I'm still okay.

    The gotcha's I've got right now are that I did update to 1.5 even though I've got the bird back down to 1.4. I think I may be screwed on the 1.5 RC. However, this is on a B RC but I still have an A RC with 1.3.2 on it. I'm still trying to figure out what I'm going to do, I've got a real mess!

    If you're lucky enough to get 1.3 or 1.4, stay there until they sort all of this crap out! JMHO, of course.

    Jerry
     
    Muva Bee likes this.
  6. Muva Bee

    Joined:
    Jan 3, 2016
    Messages:
    87
    Likes Received:
    44
    @Jtrjr got that. I have now 2.4.3 what i used with P3A.

    I monitor voltages and do i'm not one of guys who push throttle 100% for two mins in cold conditions, so battery should be fine.

    I'll try with 1.4 FW max to see if i'll get NFZ's.
     
  7. Jtrjr

    Joined:
    Mar 28, 2015
    Messages:
    444
    Likes Received:
    277
    Location:
    South Dakota
    Muva,

    Not sure about the whole "cold" battery update. I was flying this bird on 1.4, RC on 1.3 and DJI Go on 2.4.3 (mostly Litchi Android) without a hiccup in some pretty cold temps (below freezing). I've got 5 batteries and never had a single battery issue. I just screwed up doing the 1.5 update. Now I'm grounded until I sort this out. I don't dare fire everything up until I try to find some better solutions. JMHO.

    Jerry
     
  8. Muva Bee

    Joined:
    Jan 3, 2016
    Messages:
    87
    Likes Received:
    44
    I believe probably because you are reasonable experienced user of RC's & LiPo's

    But if you charge batt today, leave it around 5-10 days and take off with some 70-80% capacity, do full throttle about 2 mins in cold env & cold battery.. Yes, complicated story but i believe 1.6FW gonna help in this kind of situation ether by detecting proper batt stats or limiting propulsion output.. but this is just theory..


    Why you are grounded?
    Did you tried beta FW & app versions.. some 1.7 FW..
     
  9. Jtrjr

    Joined:
    Mar 28, 2015
    Messages:
    444
    Likes Received:
    277
    Location:
    South Dakota
    Muva,

    Yeah, pretty familiar with the Lipo's, I never take off without a freshly charged battery. If they lay around, I run 'em down and do a full charge before I fly.

    I'm just not into the whole mess that's being created with these latest releases. With all of the "hidden" and IMO "underhanded" updating with no notification of what DJI is doing to our equipment, I just don't want to take a chance on getting locked up in some unreversable scheme. I may already be there by doing the 1.5 update. I'm not firing anything up until I know for sure what's going to happen. Hopefully, I can sort it out and get the RC downgraded to 1.3.

    No biggie, I've got some other birds to fly!

    Jerry
     
  10. Zone 5

    Joined:
    Dec 24, 2015
    Messages:
    52
    Likes Received:
    10
    Is there any conscientious on the firmware and the version of Go that works best and least issues? I had the OP's same question as I have an Adv on the way and had a standard with constant signal loss that Best Buy took back. I really don't want to run into the same thing with the advanced. There seem to be a lot of signal loss horror stories on the DJI forum. Last thing I want to do is have to return this Adv or worse, have to send it to DJI. I flew my Standard for 2 weeks with no issues and then it got the signal loss and every fix did nothing. It was updated and had latest Go version