Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

VPS error

Discussion in 'Pro/Adv Discussion' started by DrewFlies, Jun 18, 2015.

  1. DrewFlies

    DrewFlies Guest

    I was flying around today and noticed my VPS was having errors. I did all the calibrations like I always do. I started up on flat surface. When the bird first launched everything was ok. I live in Florida so there are no hills/mountains. As I was flying I noticed my height was at -21.5 feet and I was hovering 10 feet above ground.. I then decided to land it. Turn off the bird reset the dji pilot app. Put the bird back up in the air and everything seemed fine. I started flying again and noticed as the bird was hovering near me about 10-15 feet in the air once again the height was off and said I was .3 ft above. Not sure whats going on but I took a screenshot and you can clearly tell the bird is above me on flat grass and the height is off. Any advice?

    [​IMG]
     
  2. Michael Olsen

    Joined:
    May 11, 2015
    Messages:
    76
    Likes Received:
    33
    Location:
    Halesite, NY
    I had the exact same thing. I was filming a sailboat race, and though the view was clearly and substantially overhead, my altitude said 19 feet, and I returned home with an "ultrasonic sensor error," and when it landed said -79 feet! Not good. New Firmware?
     
  3. DrewFlies

    DrewFlies Guest

    I have heard the VPS having errors when flying over water as its hard for the sensors to determine how high it is over water so that maybe is your issue. But, I was over solid ground so it makes no sense. Did not update firmware as I'm seeing a bunch of people are having problems. My Phantom has been flying fine and continued to fly alright today even with the VPS error. It just makes me nervous that this could be an issue later on.
     
  4. wordsmith

    Joined:
    Jun 14, 2015
    Messages:
    131
    Likes Received:
    61
    Location:
    Kelowna, British Columbia
    There is a problem, and DJI is aware of it. Check out this thread on DJI forum for more info:

    http://forum.dji.com/thread-21636-1-1.html

    Best advice seems to be to turn off VPS at this stage of the game until the problem is solved.
     
  5. DrewFlies

    DrewFlies Guest

    With over 50 flights and all perfect results and not to mention I didnt update to new firmware so it seems as if my VPS is going bad after a short amount of time.
     
  6. wordsmith

    Joined:
    Jun 14, 2015
    Messages:
    131
    Likes Received:
    61
    Location:
    Kelowna, British Columbia
    Sorry to hear that. I've only had my P3A for a few days, so it hasn't covered nearly as much ground as yours has. Until I get more air time under my belt I'm just sifting through the forums and trying what seems to be working for others. I don't fly indoors, and my P3 seems to have excellent hover stability even with VPS off, so I keep it that way. Just updated to firmware 1.2.8 but haven't had a chance to fly yet. Hopefully there won't be any new surprises.
     
  7. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    I have everything fully updated (P3P + Android) but still getting this error popping up after turning VPS on again to see if it is fixed.
    It seems to carry on flying normally after the message - which isn't surprising when VPS should not even be working a hundred feet up and 500 feet away.
    However I noticed it doing the yoyo thing when closer to the ground today (after getting the error warning).
    Also descent seemed like an on/off switch either dropping full speed or hovering?
    On landing, it thought ground was -16 feet which I haven't seen before but there have been reports of it.
    Switched VPS off again and all this sillyness stopped.

    Must say this big new feature has been worse than useless so far for me.