Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgrade Woes

Discussion in 'Phantom 1 Help' started by MrBill, Dec 2, 2015.

Tags:
  1. MrBill

    Joined:
    Dec 2, 2015
    Messages:
    1
    Likes Received:
    0
    I have a Phantom 1.2 and just upgraded the NAZA v2 to firmware version 4.02. The upgrade procedure seemed to go well. After flashing the firmware, I loaded the default settings, calibrated the transmitter, the compass, and the IMU, and re-enabled IOC. Unfortunately, when I powered-up the Phantom, the startup melody was very faint, almost inaudible, and when I tried to arm the motors, they just kind if flutter back and forth, rather than spin. After that, I tried doing a hard reset on the Naza. Following that, I re-calibrated everything, but I'm still getting the same issues - very faint volume on the startup melody and the motors only flutter, rather than spin, after arming. Any ideas how to fix this?
     
Loading...
Similar Threads - Upgrade Woes Forum Date
Fc40 upgraded battery Phantom FC40 Help Yesterday at 4:37 PM
Standard P3S upgrade downloan now no connection Phantom 3 Help Yesterday at 12:19 PM
Upgrade and register Pro/Adv Discussion Wednesday at 1:15 AM
Firmware upgrade failure - bricked P4P+ Phantom 4 Pro Help Monday at 9:04 PM
Worth buying the upgrades General Discussion Sunday at 7:00 AM