Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. clongjump

    Joined:
    Jun 12, 2016
    Messages:
    1
    Likes Received:
    0
    Let me preface this by saying I am new to the UAV community. Just bought a P4 a month ago and looking forward to learning as I go. Yesterday I noticed for the first time that my P4 was moving forward much slower than to either side or backward. I moved it closer for tests and saw that when sent in either sideways or backwards direction, the unit responded by "tilting" and moving quickly. However when sent forward, it does not "tilt" and instead moves forward at half the speed as the other directions in an almost level position.

    I dont recall seeing this in my previous flights so think it happened in the air yesterday. Prior to noticing it I was pushing the UAV by moving it quickly in all directions trying to understand how quickly it can respond. Does this sound like a hardware or software problem? I checked the settings in the DJI app and they appear the same as factory settings. I did purchase the DJI care program so may have to take advantage of that if something is actually broken. Any advice would be appreciated.

    Chris
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,236
    Likes Received:
    1,606
    Location:
    Palm Beach Co.- FL
    First-order wild guess:
    Something detected by the collision avoidance system?
     
    #2 N017RW, Jun 12, 2016
    Last edited: Jun 12, 2016
  3. DroneDestination

    Joined:
    Jan 15, 2016
    Messages:
    698
    Likes Received:
    126
    Try turning off Obstacle Avoidance. See if this evens out the speeds.