Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Uh oh, did I just brick it?

Discussion in 'Pro/Adv Discussion' started by malacca, Oct 15, 2015.

  1. malacca

    Joined:
    Apr 28, 2014
    Messages:
    66
    Likes Received:
    0
    I was updating the firmware to 1.4.0 or whatever, and it seemed like it was done, so I turned off the power, but apparently it wasn't done, so now when I turn it on, it just beeps very loudly. The Go app doesn't recognize any firmware installed on the craft. I've tried to reinstall the 1.3.2 firmware, redo the 1.4.0 upgrade, but nothing happens except for the extremely loud beeping. Am I totally screwed now? I just got it yesterday...
     
  2. TheAwesomeGuy

    Joined:
    Oct 5, 2015
    Messages:
    41
    Likes Received:
    1
    Location:
    Qatar
    format the sd card.. then do it again.. the phantom 3 can fix itself back automatically i think.. it's design that way.
     
  3. jeffreyi

    Joined:
    May 20, 2015
    Messages:
    20
    Likes Received:
    3
    Just put it in a closet and let it beep. It will last for about ten minutes and automatically then begins loading the firmware.
     
  4. EPT160

    Joined:
    Sep 30, 2015
    Messages:
    92
    Likes Received:
    15
    Location:
    Australia
  5. malacca

    Joined:
    Apr 28, 2014
    Messages:
    66
    Likes Received:
    0
    Yep, you guys are right. I just stuck it outside and let it do it's super loud beeping, and just as I was about to give up, it finished. Whew. That would have sucked. Just tried out the new POI mode, and it works like a charm!