Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Solid Beeping on start up error

Discussion in 'Phantom 3 Help' started by paulsheaves, Sep 24, 2015.

  1. paulsheaves

    Joined:
    Jul 13, 2014
    Messages:
    138
    Likes Received:
    6
    In a spot of bother folks!

    Tried updating my machine to firmware 1.3.2 because the advice is to do this before updating again to the all in one firmware 1.4.0010.

    However, the update failed a couple of times, and now all i get it this awful beeping on start up which sounds like the phantom is a ticking time bomb.

    Video here:

    Can anyone help? - I have tried different batteries and SD cards, nothing...
     
  2. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    The beeping is indicating that the upgrade failed. You may want to format the Sd card and get a new copy of the firmware upgrade and try it again. Your battery looks low too. Only see one LED.
     
    bobmyers likes this.
  3. paulsheaves

    Joined:
    Jul 13, 2014
    Messages:
    138
    Likes Received:
    6
    Trying that now... re downloaded the bin file, inserted into phantom, turned on, loud constant beeping still (its not the normal beeping for a firmware upgrade, same as in vid above) and flashing red and green gimbal light...
     
  4. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Stick it in the closet and let it beep for about 30 minutes if the gimbal light is flashing red and green. Make sure the battery is fully charged before you start because it is not on this video.
     
  5. bamaphanthom

    Joined:
    Sep 26, 2015
    Messages:
    2
    Likes Received:
    1
    I'm having the same exact problem.... Tried everything except the closet trick.
     
  6. droneshop

    Joined:
    Mar 23, 2015
    Messages:
    125
    Likes Received:
    29
    Location:
    Calgary, AB
    Have the same problem. Gimbal goes red and green for about 5 minutes then solid red.
     
  7. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    One poster got tired of the beeping so he stuck it in the closet and went back 30 minutes later and the upgrade was a success. :D:D:D
    I guess I am fortunate, I didn't have a lot of issues-- I went from 1.1.9 to 1.3.2 to 1.4.1. Could not go from 1.1.9 straight to 1.4.4.
     
  8. bamaphanthom

    Joined:
    Sep 26, 2015
    Messages:
    2
    Likes Received:
    1
    Let mine beep for an hour and everything is working properly.
     
    bobmyers likes this.
  9. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    That's the proven fix:D:D:D
     
  10. Cengiz Tapan

    Joined:
    Oct 1, 2015
    Messages:
    1
    Likes Received:
    0
    I'm having the same problem. Tried everything except the closet trick but there is no light on mine when is beeping. When I tried to do upgrade it after 5 minutes later it gone of the lights and start to do beep beep.
     
  11. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Closet trick next:D:D:D:D That was suggested in a Youtube video by a DJI dealer in the States.
     
  12. EPT160

    Joined:
    Sep 30, 2015
    Messages:
    92
    Likes Received:
    14
    Location:
    Australia
    Had a similar issue. Loud continuous squawking.

    I was on top of a sand hill and swapped out micro SD cards between batteries. I had an older version of the firmware on the card but did not realize it, so of course the P3 started to roll back the firmware and showed 'compass error' on the RC and I could not start motors. Sand hill, in the sun, not a good place to work out the issue. I rebooted the P3 several times to see if I could get it to start, which would have corrupted the firmware roll back and made it impossible to start. I also got the loud continuous squawking which does not sound good.:eek:

    I packed up and headed home but figured that I had probably corrupted the firmware with the SD card change.

    Wrote latest firmware to card and went through update procedure. The P3 squawked for a long time (25 to 35 minutes) before it eventually began the firmware update. Then all was good again!
     
    bobmyers likes this.
  13. SC History

    Joined:
    Oct 8, 2015
    Messages:
    3
    Likes Received:
    0
    I will turn it on and let it beep until the battery runs low. However, I never got to point of having my new P3 activated. I wonder whether information in the Ipad from the old P3 is causing the problem.Thanks.
     
  14. EPT160

    Joined:
    Sep 30, 2015
    Messages:
    92
    Likes Received:
    14
    Location:
    Australia
    I would not have thought an issue. But I only have the one phantom.

    If your are updating firmware then the RC should be switched off and not get any info from your app.
     
  15. SC History

    Joined:
    Oct 8, 2015
    Messages:
    3
    Likes Received:
    0
    VERY HELPFUL AND VERY IMPORTANT. AT FIRST I QUICKLY TURNED OFF THE BATTERY BECAUSE THE BEEPING WAS ANNOYING. YOUR SUGGESTION WORKED. I LEFT THE BATTERY ON AND AFTER 10 MINUTES IT STOPPED BEEPING AND I WAS ABLE TO SUCCESSFULLY COMPLETE THE SETUP.