Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Think Twice! New update [didn't break] my Phantom

Discussion in 'General Discussion' started by TickTock, May 10, 2013.

  1. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    [Update: My problem turned out to be the compass being install on the wrong leg and NOT the update :oops: . Probably still good advice to think twice if you like how your Phantom flies, but I no longer have any significant issues with 3.10. ]

    Since there seems to be a lot of encouragement to move to the new firmware, I wanted to start this thread to ensure anyone thinking of updating thinks twice. My Phantom was great prior to the update. Amazing really. Would just sit in the air, lean into the wind, and stay. I could let go of the controls for minutes and it wouldn't budge (I did this once when my wife came out to ask a questions and it just hovered where I left it the whole time).

    HOWEVER, I made the mistake of updating to the new rev. Now GPS mode is unusable. ATTI is still great - smooth, doesn't drift unless there is wind. As soon as I flip to GPS, though, it picks a random direction and flies off (I can override with the stick, but it is a constant battle). I still hope to find some configuration that will fix it but if you like the way your Phantom flies my recommendation is to leave well enough alone.
     
  2. MX45OR

    Joined:
    Feb 18, 2013
    Messages:
    161
    Likes Received:
    0
    Re: Think Twice! New update broke my Phantom

    In other forum posted another solution.
    Download "Default Phantom Parameters" from DJI website and then do IMPORT from Toools Menu. Re-do Calibration always.
     
  3. denodan

    Joined:
    Feb 8, 2013
    Messages:
    359
    Likes Received:
    23
    Re: Think Twice! New update broke my Phantom

    If I remember correctly, after the update, it told me to do an advanced calibration, other then that it did not change any of my other settings.
     
  4. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Re: Think Twice! New update broke my Phantom

    TIP:
    If you import Phantom Default Parameters and you have other than stock TX, must change control from PPM to TRADITIONAL
     
  5. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Re: Think Twice! New update broke my Phantom

    Importing default parameters didn't help. Everything is stock.
     
  6. Mr. Lucid

    Joined:
    Apr 29, 2013
    Messages:
    28
    Likes Received:
    0
    Re: Think Twice! New update broke my Phantom

    did you also check your compass calibration?
     
  7. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1