Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Stuck in GPS Mode

Discussion in 'Phantom 2 Vision Help' started by V2AIR, Feb 18, 2014.

  1. V2AIR

    Joined:
    Feb 18, 2014
    Messages:
    3
    Likes Received:
    0
    Have a Phantom Vision that starts up fine in Att mode, but once you switch to GPS mode, it will not switch back into Att mode no matter what the switch position is. Any ideas?
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Are you running in default Vision mode or have you changed to NAZA mode using the Assistant software?
     
  3. V2AIR

    Joined:
    Feb 18, 2014
    Messages:
    3
    Likes Received:
    0
    It's in normal Phantom mode. The rear right leds are sometimes flickering between green and yellow even through the left rear stays yellow during startup. One front ESC was already replaced because the red led lights stopped working. I'm wondering if this speed control also has issues. Flies perfectly in GPS. It is not my unit, it belongs to a customer. Just trying to problem shoot it for him. Every update is up to date, even the TX.
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Ah, I just wondered because in stock Vision mode you can't manually select atti mode. If the unit detects fewer than 6 sats then it will go into atti mode automatically, and when it gets 6 or more go into GPS automatically. Yellow led signals indicate it doesn't have sufficient sats to run on GPS mode. If the LEDs are not behaving equally then it could point to one ESC module having a bad time. If they are both doing it then it might point to an unhappy GPS module.