Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

replaced motors and esc and copter flights in circles during liftoff

Discussion in 'Phantom 2 Help' started by georgefrombc, Feb 13, 2016.

  1. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    i replaced my motor and one esc. all the motors turn good but when I go to take off with the copter my phantom 2 goes in circles and crashes. I recalibrated the compass when I made changes also. I have broke a few props now and I am not sure what is happening. pleaseee help. thanks everyone
    replaced the motors with the t motors.
     
  2. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,694
    Likes Received:
    3,424
    Moving in a circle sounds like toilet bowl effect which is a classic symptom of a bad compass calibration.
     
  3. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    I did a compass calibration a few times out one the field. It is really weird because before I changes the montors and esc I did not have any problems at all. I will try again tomorrow and see what happen. hopefully I do not damage anymore props.
     
  4. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Why did you replace the motors and ESC module in the first place? Were the motor that you replaced the same as the rest? The newer P2.s used 2312 motors and the older (first P2 models) used the 2212 and they cannot be mixed.
     
  5. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    i was adding a black mamba to my copter and forgot to add the prop guards with the longer scews jason. when i added the longer scews without the guards i screwed them to the motors. screwed them all. then i replaced all the motors with t motors and burnt up an esc. been a rought go and i just wand to fly my copter. will try to recalibrate and try some other stuff today and hope this works. thanks everyong.
     
  6. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    But you really haven't answered the question of which motors were the originals 2212 or the 2312 and did you replace the damaged motors with exact replacements. It's very easy to order the wrong motors and not know it. When did you buy the P2 and was it new or used?
     
  7. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    i bought the unit used. i am not sure what the motors are as i am looking at one right now and there is no number on them. the t-motors i bought where mn-2214 for the phantom 2. is there somewhere i can find if i have the wrong motors. i am new at this and this is my first quad and still trying to get the hang of of this terminology.
     
  8. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    thanks for all the help and i really apprieciate all the information. jason i keep reading your replies and no i have the t motors and not the original ones. tried to do an upgrade since i had to replace the motors for more power and the guys on youtube said they are one of the best ones to use.
     
  9. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Take the prop the original CCW motor with the black hub and if the top of the shaft has a black dot it's a 2212 motor. Now if the motor shaft is all black then they are the newer 2312 motors. Of course I'm assuming you damaged one of each motor ccw and cw.
     
  10. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    i actually damaged all 4 motors when i put the screws in with no prop guards .the motors would be the 2212 ones and they do have the black dots on the tops for ccw and cw. i am going to try to redo all the updates and an advanced ecm and going to see if it helps at all. thanks again for all the info.
     
  11. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Check that you wired them correctly according to the photo
    IMG_0016.jpg IMG_1549.jpg
     
  12. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    More then likely if those t motors are faster then 960KV they are to fast for both the props and ESC modules depending on how old the P2 is since you bought it used.
     
  13. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    i am starting to think you are right jason. i might just have to replace all the esc. what do you think. i have bought an extra one, do you think i should buy two more and replace them all. the wiring on the motors are the exact for what t motors states. the other thing i am starting to think is this is the older and first version of the p2 as what you have described from what the motors look like. thanks again jason and talk to you soon
     
  14. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    You can one of two things replace those t motors with the original motors or replace all for with the newer 2312 motors and 4 ESC v2.1 modules for a total cost $110.89 USD. Personally I really don't care what someone on youtube told you about those t motors because the real reason you crashed is due to those motors and unbalanced P2. So either fix it right or not at all.
     
  15. georgefrombc

    Joined:
    Feb 13, 2016
    Messages:
    8
    Likes Received:
    0
    well thanks jason for the information. i will replace the motors as that is the major problem with the quad. thanks again