Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Remote wont connect to device

Discussion in 'Phantom 3 Help' started by Seabass, Mar 5, 2016.

  1. Seabass

    Joined:
    May 18, 2015
    Messages:
    23
    Likes Received:
    6
    I can no longer get any device to connect to the phantom. RC will connect to the phantom the device will not there is no camera view. And some of the devices will not connect at all.. please help
     
  2. Seabass

    Joined:
    May 18, 2015
    Messages:
    23
    Likes Received:
    6
    I have had my phantom since June . I have flown a lot with no problems. I put it away in October for the winter just got it out last week updated it and flown once. Said I needed to update the RC. RC wouldn't update then just wouldn't comnect at all anymore
     
  3. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    So RC will connect but the device tablet/phone will not?

    Do you see any "radar" in bottom left or gps map in lower right of debice screen?
     
  4. Seabass

    Joined:
    May 18, 2015
    Messages:
    23
    Likes Received:
    6
    Yes RC will connect but tablet/phone will not. I cant even get my tablet to connect at all it doesn't go to camera view. Just says" how to connect" my samsung 3 phone goes to camera view but there is no camera. And yes I can see the radar just no camera view its blank.
     
  5. Seabass

    Joined:
    May 18, 2015
    Messages:
    23
    Likes Received:
    6
    Ok made some progress. I hooked up a I phone 6 plus and everything worked! So I am thinking it must be a android problem? Samsung tab wont connect and samsung s5 and s3 phones wont connect
     
  6. ScopeTech

    Joined:
    Nov 21, 2015
    Messages:
    221
    Likes Received:
    59
    Check USB debugging status, in Settings, Developer Options down near About Phone, if it's not there go in to About Phone and scroll down to Build Number and tap on that seven times in a row, then go back to previous menu and then in to Developer Options and make sure USB debugging is enabled. If it already is, try turning it off, then using the option below it to revoke USB debugging permissions, then reboot the device, go back in to turn USB debugging on, try reconnecting remote.
     
  7. Seabass

    Joined:
    May 18, 2015
    Messages:
    23
    Likes Received:
    6
    Thanks so much! It worked the only problem is it has to be done every time. Which I can deal with its better than never flying
     
  8. ScopeTech

    Joined:
    Nov 21, 2015
    Messages:
    221
    Likes Received:
    59
    Good to hear! One more thing, in the Go app go to 'Me' (before connecting to the aircraft in Equipment) and tap the gear in the top right, there's a USB debugging option there as well.
     
  9. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    Great! Looks like you are well on your way back to flying.