Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom II Vision Plus 3.0 WiFi module issue

Discussion in 'General Discussion' started by Hendricks, Apr 14, 2016.

  1. Hendricks

    Nov 16, 2014
    Likes Received:
    Hi Guys,

    Out of the blue one day, I lost the video feed to my phone from my Phantom II Vision Plus 3.0.
    I use my iPhone 5s with my aircraft and this is the first issue I have ever had with the two Phantoms I have owned over the last few years.
    I checked with my DJI dealer(Flying Cameras in Vancouver,BC.) and was told to contact DJI directly.
    I did so, and was told that the loss of video could be due to a few things:
    Needed software updating to my aircraft.
    Re-binding my controller.

    I let DJI know that I had done all software upgrades and did the re-binding.

    The DJI tech rep also mentioned that since I was using an Apple product, that I should be sure to re-set my iPhone, once I had done the other things.
    The rep said re-setting the phone could solve the problem with the loss of video.

    If it doesn't, then I will have to replace the WiFi module and that DJI would 'issue me a ticket' and the module would be free. However, I believe I would have to contact DJI, have them send me a shipping box and pack up my aircraft and have it shipped to California, where the replacement of the WiFi module would take place.

    If I wanted to avoid all this hassle and save myself lots of time, then I would simply contact my dealer and fork over the $250 and they would send me a new module and I would install it myself.

    I wonder if others out there have run into the same problem?

    But, right now, I'm grounded until my module is replaced. :(
  2. boglll

    Jul 19, 2015
    Likes Received:
    Same drone and same problem. Shipped to Dji Europe, had it back perfectly fit. Just paid shipment to Netherlands, it took about 1 month have it back...
  3. Mark The Droner

    Aug 26, 2015
    Likes Received:
    Brookeville, MD, USA
    Remember the signal to your phone does not come from the aircraft, it comes from the extender. There's another signal that comes from the aircraft to the extender. So it could be your extender. Or it could be your wifi module in the aircraft. There was a thread not too long ago that discussed that range extenders were "bricked" after an update. There's another thread that discusses why wifi modules in P2V+ aircrafts were failing due to overheating. Good luck.