Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 GPS Questions when in "Phantom" Mode

Discussion in 'Phantom 2 Discussion' started by Lukevia, Feb 10, 2015.

  1. Lukevia

    Aug 26, 2013
    Likes Received:
    After quite a bit of google and searching the forums, I feel I must need a lesson in searching for answers. Apologies if this has been discussed elsewhere although I'm unclear on some things.

    I have a P2 - firmware 3.08 (all updates installed), no crashes ever, and recently installed the anti static compass.

    When in normal "Phantom" mode, the bird does not detect a GPS (two yellow lights only, no green or red alternating lights). The Naza assistant shows only "normal flight" in the control mode switch settings although I believe this is normal for P2s when in "Phantom" mode. When powered on, I have recalibrated the compass but still see only slow yellow blinking lights. I've checked the puck under the copper foil (no cracks or damage), checked the connection to the main board, checked compass connection, tried installing original stock compass again, and reinstalled the firmware update. I still have no GPS detected - at least that is what the lights on the bird indicate.

    This was concerning until I remembered I installed the firmware update and my bird was no longer in "Naza M" Mode. As soon as I switched to Naza M mode, viola! I had green and red alternating lights and could get the GPS signal.

    Switching back to "Phantom" mode however, I see the same yellow lights. In the user manual, I see "Phantom 2" in the upper right corner of the Naza assistant, although on my screen, I see only "Phantom" appear in the upper right corner. Is that normal?

    I'm not sure if what I'm experiencing is odd. Shouldn't I still be able to pick up a GPS signal when in normal Phantom mode? I'm confused about this because, while I'm perfectly fine flying in Naza M mode with IOC enabled, I'm curious if I'm missing anything here.

    Thanks in advance for any clarification/help offered.
  2. Hughie

    Nov 22, 2014
    Likes Received:
    Leeds, United Kingdom
    Are you sure you are not in ATTI mode?

    Connect your RC to the RC assistant and check your S1 is working properly when with GPS selected.