Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Battery will not turn on

Discussion in 'Phantom 2 Help' started by gholland, Dec 25, 2013.

  1. gholland

    Joined:
    Dec 25, 2013
    Messages:
    2
    Likes Received:
    0
    Just received my new Phantom 2. Charged the batteries, put the machine together, as shown in videos ... and it seems I have an issue.

    I insert the main battery into the machine, press the button for 2 seconds, and it will not turn on. The 4 battery indicator lights, light up showing full charge, but the red "button light" blinks, 11 times, then turns off.

    I can find no troubleshooting information to help. Anyone have any ideas what is going on here?

    Thanks,
    -gary
     
  2. Shedracer

    Joined:
    Sep 7, 2013
    Messages:
    136
    Likes Received:
    0
    Location:
    Oxfordshire, UK
    Silly question maybe, but when you say you are pressing the button for 2 seconds, have you not done the "press button once then immediately again and hold until the phantom fires up"? If your only pressing it once for 2 seconds, it won't start! Hope this helps.
     
  3. arinvideo

    Joined:
    Nov 7, 2013
    Messages:
    158
    Likes Received:
    1
    What shedracer said Click once then hold
     
  4. gholland

    Joined:
    Dec 25, 2013
    Messages:
    2
    Likes Received:
    0
    Well, now I feel like a dummy ... I didn't see that on the video or docs. I pressed once then held for 2 seconds and the unit powered up.

    Thanks!
     
  5. THell

    Joined:
    Dec 7, 2013
    Messages:
    97
    Likes Received:
    0
    Dji has a vid about powering it on it is on the vision side. Same frame just no camera
     
  6. Drowe26

    Joined:
    Jun 8, 2015
    Messages:
    5
    Likes Received:
    0
    I'm having the same problem, except that I have followed the instructions and my Phantom won't turn on. I've watched the video and tried multiple combinations. Any ideas?
     
  7. TeamYankee

    Joined:
    May 30, 2014
    Messages:
    491
    Likes Received:
    42
    Location:
    Swansea, Wales, UK
    Start your own thread on this.. the original poster has resolved the issue.