Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P will never connect on 1st try

Discussion in 'Pro/Adv Discussion' started by wlkngmachine, Jul 14, 2016.

  1. wlkngmachine

    Joined:
    Jan 6, 2016
    Messages:
    22
    Likes Received:
    2
    Whenever I go to launch my P3P i turn on the RC first, then the aircraft, then open the app. Except everytime the first time i try to connect, the app wont recognize the aircraft. Then I have to boot the aircraft down, boot the RC down, close the app and repeat the process. It always works on the second time. What gives!?!?!?
     
  2. ROD PAINTER

    Joined:
    Dec 12, 2015
    Messages:
    185
    Likes Received:
    48
    Open the app 1st, go to camera then turn on AC. Works for me every time on my p3p!


    Sent from my iPhone using PhantomPilots mobile app
     
  3. m0j0

    Joined:
    Dec 26, 2015
    Messages:
    1,536
    Likes Received:
    530
    Or you can turn on the RC, turn on the tablet then plug in the cable.... Usually prompts me to decide what app I want to open. That usually works for me.


    Sent from my iPad using PhantomPilots mobile app
     
  4. ROD PAINTER

    Joined:
    Dec 12, 2015
    Messages:
    185
    Likes Received:
    48
    Thanks for correcting me. I meant to say rc,app,camera,ac
     
  5. wlkngmachine

    Joined:
    Jan 6, 2016
    Messages:
    22
    Likes Received:
    2
    interesting, thanks for the replies, i'll give that a try. I usually turn on the rc, connect my iphone 5s, and then turn on the ac, then open the app. I've never gotten a prompt to open the app when connecting my phone tho.
     
    telescott likes this.
  6. telescott

    Joined:
    Oct 5, 2015
    Messages:
    251
    Likes Received:
    89
    It is strange some people have issues. I have three P3P's and I always turn on the transmitter with the USB cable connected, and like m0j0 it prompts me to decide whether to open Litchi or DJI Go (since I have both apps installed) app I want to open. I chose DJI Go and then click on "camera" at that point I turn on the quad and it works every time. (Device:Android Galaxy Note 4).
     
  7. Shammyh

    Joined:
    Apr 4, 2015
    Messages:
    325
    Likes Received:
    154
    Rebind controller to aircraft. Usually helps with stuff like that.
     
  8. Vertigo

    Joined:
    Jun 12, 2016
    Messages:
    499
    Likes Received:
    148
    Wont change a thing, the controller connects just fine to the phantom.

    I have the same problem. Worse if I want to switch between litchi and go. I usually end up unplugging the usb cable, killing all apps, replug usb cable and then it usually works.
     
  9. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,236
    Likes Received:
    915
    Location:
    Indy, USA
    If you have android the process is to have the GO app device powered on. Do not open the GO app at this point! Power up the R/C. At this point the R/C will enable the GO app and open it to the point of the GO app's home page instructing you to enable your aircraft. Once aircraft is powered up return to the app and it, the GO app, should be live and ready to go.
     
    #9 flyNfrank, Jul 15, 2016
    Last edited: Jul 15, 2016
  10. z28lt1

    Joined:
    Jul 15, 2016
    Messages:
    13
    Likes Received:
    1
    I often have the same issue. On IOS, I simply unplug the cable to the ipad, and plug it right back in and it works fine.
     
  11. Wyattroa

    Joined:
    May 31, 2016
    Messages:
    104
    Likes Received:
    32
    I always power on the AC first, then the RC. After the RC is powered on it prompts me to pick either dji go or litchi. Never have an issue doing it this way and by the time I get everything else fired up the sats are strong.
     
  12. mfr1340

    Joined:
    Jun 16, 2015
    Messages:
    29
    Likes Received:
    3
    No, read the directions, RC first, Drone second, DJI Go app last, when the camera connect button turns blue, press it.