Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced P3A No Video Signal

Discussion in 'Phantom 3 Help' started by ShadoX, Sep 12, 2015.

  1. ShadoX

    Joined:
    Sep 10, 2015
    Messages:
    3
    Likes Received:
    0
    Location:
    Temecula, CA
    I just got my brand new P3A from the Buydig deal a few weeks ago. Since I took it out of box and it up I have very rarely been able to get any type of video signal even when the Phantom is directly in front of me, despite it having a good connection will full bars. I am using an iPad Mini 3. Everything else appears to be working perfectly.

    While trying to figure out the problem I noticed that the feed would start working when I had the aircraft on but had the nose pointed at the sky. From there I figure maybe it was a loose cable or maybe there was so kind of calibration which made it think it was pointed the wrong way.

    Since then I have tried:

    Updating to the latest FW.
    Making sure the ribbon cable ends are pushed in all the way.
    Re-calibrating the IMU.
    Re-calibrating the Gimbal.
    Trying various channels (with 32ch method) in an open field.
    Various MicroSD cards
    An Android Device
    Various Cables (for both iPad and Android)

    One thing I have noticed today is if I rest the aircraft on the rear legs while it is in Camera Mode I get a perfectly good signal with no lag. However the minute I start moving it it quickly goes to no signal.

    Anyone have any ideas? Should I have DJI Fix it or just exchange it?
     
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    The only times I have had connection issues with mine were when the firmware on the Controller was 1.3.2 and 1.1.9 on the Phantom. It would disconnect after about 5 seconds after booting up. The other issue was no picture and the camera hanging down. Reformatted SD Card and that was resolved.
     
  3. ShadoX

    Joined:
    Sep 10, 2015
    Messages:
    3
    Likes Received:
    0
    Location:
    Temecula, CA
    Tried this a bunch of times already to no avail. I've had maybe 2 flights where video SORT OF worked, but it was still very flaky.

    Pointing the nose up always make it work though, I think I may just have to get a replacement.