Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced P3 Advanced, App says no signal but can still see camera

Discussion in 'Phantom 3 Help' started by greengangster01, May 28, 2016.

  1. greengangster01

    Joined:
    May 28, 2016
    Messages:
    2
    Likes Received:
    0
    I just got my new drone, charged all the batteries, put it all together. and i got it in the air for about 5 seconds just to make sure it worked then i landed it. I then turned everything off and came back half hour later. The app said it needed a firmware update, so i did the updates and now when i try to turn the gimbal on the controller or do anything it wont let me. The app says no signal but i can see the camera plain as day. Also when the app starts up it says beginners mode activated which is fine, but when i go into the settings it is off and when i turn it back on the slider goes back to the off position after about 5 seconds. I cant calibrate the compass or anything. I tried reinstalling the app and relinked the controller to the drone but still same issue. Any help would be appreciated. Thanks.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,832
    Likes Received:
    5,546
    Location:
    US
    It sounds like you installed the firmware update on the remote controller via DJI GO and forgot to install it on the Phantom itself. Take a look at these instructions to ensure you did not miss any important steps.
     
    greengangster01 likes this.
  3. greengangster01

    Joined:
    May 28, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks, now that i think of it i did format the card after that initial flight from the tablet as i was cruising through some settings. Hopefully it works, Thanks again