Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2 with H3-3D Gimbal Crashed

Discussion in 'Phantom 2 Discussion' started by mikouk, May 13, 2014.

  1. mikouk

    Joined:
    May 13, 2014
    Messages:
    21
    Likes Received:
    0
    HI Guys

    First post here. I wondered if you could help. I've just been flying my P2 in moderate wind. Third flight today. All going fine when I lost all control. The p2 started pitching and yawing and dropped to the ground. Unfortunately I wasn't filming. The motors were still working but it dropped pretty fast. I gave it full throttle but nothing happened.

    MOST IMPORTANTLY it didn't hit anyone but it's given me quite a shock as there was someone nearby. I guess I've learnt a valuable lesson and will never fly again above or near people. In fairness I didn't know they were there but still…. It's brought home how dangerous these things really are.

    So what may have caused this?

    btw There doesn't seem to be any damage to the p2, gimbal or go pro.

    Thanks
    Mark
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Thread moved to P2 section.

    Were you descending when it lost control? Coming straight down too fast can cause the kind of behavior you described.
     
  3. blakeavant

    Joined:
    May 12, 2014
    Messages:
    3
    Likes Received:
    0
    We experienced erratic behavior after switching props and using a prop that could have been out of balance. We've ordered a new prop balance to make sure all of the props are balanced. We always thought it was just for video quality, but it appears that vibrations can cause the autopilot functions to get rattled and make the craft uncontrollable. I'm still trying to verify the findings but once our prop balancer arrives I'll report back how far out of balance my props are.
     
  4. mikouk

    Joined:
    May 13, 2014
    Messages:
    21
    Likes Received:
    0
    Hi Guys,

    I was descending but not quickly. I was bringing it in to land. It was about 20ft from the ground. I was up on a ridge so it was level with me hence I couldn't see what was below it. (stupid I know)

    The props were used but I'd never crashed it before in the previous 30 ish flights. I check them all before I take off to make sure there aren't any nicks etc. One now has a slight chip so I'll bin it.

    I'll also order a balancer to make doubly sure. The problem I have now is I'm on holiday doing some shots for a friend so I need to get it up flying again. I think I'll take it somewhere completely deserted when I try again. I still can't get over what could've happened had it hit someone. At least I had the protectors on but it would still have hurt a lot!!

    Thanks for the ongoing help
    Mark
     
  5. ianwood

    ianwood Taco Wrangler
    Staff Member

    Joined:
    Jan 7, 2014
    Messages:
    4,922
    Likes Received:
    1,797
    Location:
    Lost Angeles
    If you have video of the crash, post it up and we can probably figure out what happened.
     
  6. Madwak

    Joined:
    Apr 2, 2014
    Messages:
    291
    Likes Received:
    1
    DJI recommend not fitting prop protecters to the P2Z due to the weight so that probably explains you're crash.
     
  7. mikouk

    Joined:
    May 13, 2014
    Messages:
    21
    Likes Received:
    0
    Thanks guys but unfortunately I wasn't recording at the time! I was just doing a quick test flight to set up a shot.

    Is that true about the protectors then? It was flying the other 30 times fine. Never seemed to struggle. It's just there are people and many trees where I'm flying and I'm not keen on flying without them. Obviously from now on I'll keep well away from people but just to be safe I'd rather keep them on.

    If it's true they shouldn't be on I'll have to have a rethink.

    Thanks
    Mark
     
  8. Madwak

    Joined:
    Apr 2, 2014
    Messages:
    291
    Likes Received:
    1
    Bottom of page 2 mentions the prop guards, http://download.dji-innovations.com/dow ... ote_en.pdf
     
  9. mikouk

    Joined:
    May 13, 2014
    Messages:
    21
    Likes Received:
    0
    Oh yes. how bizarre. Thanks for that.

    I'm not sure what to do now.
     
  10. mikouk

    Joined:
    May 13, 2014
    Messages:
    21
    Likes Received:
    0
    Another thought. I was running the old firmware. Would that make any difference?