Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motor Problem?

Discussion in 'General Discussion' started by Rsa, Jul 27, 2015.

  1. Rsa

    Rsa

    Joined:
    Jun 18, 2015
    Messages:
    6
    Likes Received:
    0
    I have a virtually new Vision + that I flew 2 times with no issues. When I went to attempt a third flight the next day a problem occurred. When I activate the quad for flight all the props begin to spin in standby mode. Then one of the props cuts out for a split second. It begins to do this continuously. Does anyone have a suggestion on what I can check?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,020
    Likes Received:
    5,598
    Location:
    US
    Are you or were you using prop guards?
     
  3. 750r

    Joined:
    Nov 27, 2013
    Messages:
    1,226
    Likes Received:
    420
    Location:
    Pa, USA
    Are the lights on that arm doing anything when the motor acts up ? Pop her open look for a weak joint .
    Welcome to the forum .....
     
  4. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Have you completed any of the calibrations for the RC or IMU as well as the compass calibration?
     
  5. Rsa

    Rsa

    Joined:
    Jun 18, 2015
    Messages:
    6
    Likes Received:
    0
    Yes, I am using prop guards. I even loosened the screws to make sure nothing was binding.
     
  6. Rsa

    Rsa

    Joined:
    Jun 18, 2015
    Messages:
    6
    Likes Received:
    0
    I always do the compass calibration each time. Doesn't take long and good habit to get into I'm told.

    Not sure if I did the other calibrations a few weeks ago when I first opened it and updated the firmware.
     
  7. Rsa

    Rsa

    Joined:
    Jun 18, 2015
    Messages:
    6
    Likes Received:
    0
    Thanks. Lights are normal. I guess I'll take a look inside for something loose.