Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Litchi with non DJI battery on 1.5.70 frimware

Discussion in 'Phantom 3 Help' started by nikolay100, May 2, 2016.

  1. nikolay100

    Joined:
    Feb 23, 2016
    Messages:
    4
    Likes Received:
    0
    Hi!
    Can anyone confirm that the Litchi app is working with non DJI batteries, but with the new firmware 1.5.70 on the bird?
    Thanks in advance.
     
  2. guchino

    Joined:
    Jan 30, 2016
    Messages:
    31
    Likes Received:
    2
    Can't use with 1.5.70 
    It is available with before 1.4.60