Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi Waypoint Gimbal when out of Range

Discussion in 'Pro/Adv Discussion' started by bkushner, Sep 5, 2016.

  1. bkushner

    Joined:
    Jun 16, 2016
    Messages:
    339
    Likes Received:
    55
    Location:
    New Jersey
    I will be out of range for my flight, so I see Focus POI won't work because I'm out of range of controller, will Interpolate work?



    Waypoint Gimbal Pitch
    Litchi can control the gimbal pitch automatically during the mission, as long as the aircraft is within range of the remote controller. To specify how the gimbal pitch should be controlled, each waypoint has a Gimbal Pitch setting which can be one of the following:

    • Disabled: The gimbal pitch control will be manual from this waypoint.
    • Focus POI: Litchi will automatically control the gimbal pitch from this waypoint to the next to keep the selected POI in the center of the frame. The POI altitude will be taken into account to determine the gimbal pitch angle.
    • Interpolate: You can specify the gimbal pitch angle at this waypoint. For "Interpolate" to work, the previous or next waypoint need to be set to "Interpolate" as well. Litchi will then automatically adjust the gimbal pitch angle to start and end at the specified angles, and smoothly transition while travelling between the two waypoints.
     
  2. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Interpolate - FYI this weekend I sent my bird on a Litchi WP mission. The first 4 WPs, interpolate was successfully executed. However all other WPs set to interpolate after that did not work. It was set based on your comments above. Did not disconnect at all so that's not the cause. I sent Litchi support an email questioning this but they don't have an explanation yet. This happened as well on a previous mission 2 weeks ago. Only in the beginning interpolate was executed. All other ones after that did not happen.


    Sent from my iPad using PhantomPilots
     
    bkushner likes this.
  3. Wolffboy

    Joined:
    May 16, 2016
    Messages:
    14
    Likes Received:
    4
    I am having a similar issue - I have a 14-waypoint mission with a POI on WP 4-8 and then WP 9-13 are all interpolated with -80* angle set. Th gimbal never moves from what looks like 0*
    Just started using Litchi a few days ago so still learning all the fine points. Phantom Filmschool has some decent videos.
     
  4. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    FYI, I sent Litchi my WP mission and he ran it through his simulator. Per his comments, "I tested it using a simulator DJI provides for developers. It produces the same results you get in real conditions if you have signal all the way." He said the mission executed just fine. Since there was signal degradation (45%) at WP9 during the actual mission, I accept that Interpolate may have failed. But on WP17 where signal was 100%, his simulation worked but not during the real mission.


    Sent from my iPad using PhantomPilots