Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Litchi - Required Firmware

Discussion in 'Phantom 3 Help' started by Take Flight, Jul 13, 2016.

  1. Take Flight

    Joined:
    Jul 6, 2015
    Messages:
    21
    Likes Received:
    5
    Hi.

    I would greatly appreciate some help and advice with getting started with Litchi. I'm not sure what firmware I need to download if any. Currently I'm using very old firmware (think 1.4) and don't want to update to the newest firmware if it doesn't work with Litchi or I don't have to to use it.


    I have a P3 Advanced and us an iPhone 6 and mini iPad 2. iPhone will just be for FPV Goggle mode.

    Thanks in advance for help.
     
  2. MikeON

    Joined:
    Nov 5, 2013
    Messages:
    277
    Likes Received:
    29
    Location:
    Pennsylvania, USA
    I use 1.6.40 in my P3A and Litchi (iOS) 1.9.2.
    Litchi has their own forum. I suggest you post your question there:
    Google Groups