Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi mission execution lag

Discussion in 'Pro/Adv Discussion' started by Rideswings, Jun 25, 2016.

  1. Rideswings

    Joined:
    Jun 25, 2016
    Messages:
    124
    Likes Received:
    8
    I hope this is the right place to post this.

    I have been using Litchi Android for around a month now, and I am happy with it overall. I have used it on around 20 or 30 missions, and it works ok. The problem I am having is that the missions sometimes take up to a minute to execute after I press go. This has happened a few times before and I just patiently hovered near waypoint 1 until either I get an error message, or the mission begins to execute. Today I waited and waited, and then thought the mission execution failed but I was wrong. The motors were still at idle, when the P3A jumped into the air and seemed like it started its mission. I pressed RTH and it ended flying into an obstacle and crashing.

    Has anyone else had this issue with delays in mission execution? Until I get it back to 100% reliable, I am hesitant to use it on long missions.
     
  2. mikesmiley

    Joined:
    Apr 3, 2016
    Messages:
    452
    Likes Received:
    264
    Location:
    Sacramento, CA
    You are uploading one hell of a lot of data to the bird when you press go. Enough data that it will go exactly where you told it to go and return, regardless if it loses connection to your remote.

    It's normal.
     
  3. shockwave199

    Joined:
    Dec 19, 2014
    Messages:
    1,067
    Likes Received:
    405
    I often do up to 32 waypoint missions and it never takes that long, ever. My missions upload in around 5-8 seconds after I hit play. Unless you have BIG waypoint totals, something doesn't seem right.
     
  4. mikesmiley

    Joined:
    Apr 3, 2016
    Messages:
    452
    Likes Received:
    264
    Location:
    Sacramento, CA
    I reckon a minute really is a long time. Mine take a good ten seconds to fire up the props and fly away, which seems like a long time, but if you're serious about a minute, then something is wrong. My bad.
     
  5. mikesmiley

    Joined:
    Apr 3, 2016
    Messages:
    452
    Likes Received:
    264
    Location:
    Sacramento, CA
    Maybe try a full and clean uninstall of Litchi, and then install it again.
     
  6. shockwave199

    Joined:
    Dec 19, 2014
    Messages:
    1,067
    Likes Received:
    405
    I should also note that I load my missions while my phantom is 50' up already. I don't load and auto takeoff from the ground which I suppose could add a little more time, but I have no experience doing it that way. I don't like auto take offs or landings at all,be it an app or manual flight. Not my style.
     
  7. Rideswings

    Joined:
    Jun 25, 2016
    Messages:
    124
    Likes Received:
    8
    Thanks for all the responses. For this mission, I had a total of around 50 waypoints, so that might be what the delay in execution is. Prior to this I only used around 5 - 10 waypoints.

    Im still getting to know Litchi, so what would be the safest way to execute a mission once waypoints are programmed in and the mission is saved? I usually use the Mission hub on my desktop to plan missions and then open them on my tab prior to flight. What I have been doing is taking off and hovering around 16' off the ground not far from waypoint 1, then hit the play button to start the mission. I usually make waypoint 1 low and near to my home point. I dont usually use the auto take-off feature but I might have had it turned on for some reason this time.

    Thanks again for the responses.