Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi compatibility

Discussion in 'FPV (First Person View)' started by Memtenn60, Jun 4, 2016.

  1. Memtenn60

    Dec 28, 2013
    Likes Received:
    Doe's anyone know if the Litchi AP is compatible with Apple iPhone 5 for the Phantom3? It is not with the DJI-GO. Litchi AP only says must have iOS 8 or newer. Unable to get info from Litchi and don't want to pay $19.99 two download it if it does not work. I also don't want to pay $400+ to get new iPhone just for my FPV goggles.
  2. aljoseph

    Nov 28, 2015
    Likes Received:
    The Litchi app is for IOS devices running IOS 8 and newer and is not device dependent. So it should work with your iPhone 5. Also, the Litchi app is not used with DJI GO. It is an independent stand alone operating system used instead of DJI GO. You should not run both apps simultaneously as they are not compatible with one another.