Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Iphone 5

Discussion in 'Pro/Adv Discussion' started by Newly, Dec 9, 2015.

  1. Newly

    Joined:
    Dec 5, 2015
    Messages:
    124
    Likes Received:
    7
    Location:
    BC
    Has anyone used the iphone 5 with AJI Go a p3 Pro, if so how does it perform, are there any glitches?
     
  2. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,537
    Likes Received:
    1,486
    Location:
    Sacramento CA
    It wasn't until mid to late October that the GO app could be downloaded on an IP5 at all. Before then, there would be the "device incompatible" error message and the download would cease. Now GO can be downloaded to older devices, but IMHO it wont give the best experience.
     
  3. Newly

    Joined:
    Dec 5, 2015
    Messages:
    124
    Likes Received:
    7
    Location:
    BC
    Thanks OSO, I will try it and let you know, however I won't be rushing out to buy another device just yet.
     
  4. Bambola

    Joined:
    May 26, 2015
    Messages:
    117
    Likes Received:
    33
    Location:
    Suffolk UK
    When I bought my p3a in July I used my iPhone 5s with no issues apart from small screen then upgraded to a mini2 which is great, not sure what Oso means about October as mine worked fine way before that?
     
  5. Scratch

    Joined:
    Nov 10, 2015
    Messages:
    94
    Likes Received:
    37
    I have a P3A and use an iPhone 5s with no problems. (Other than screen envy)
     
  6. Newly

    Joined:
    Dec 5, 2015
    Messages:
    124
    Likes Received:
    7
    Location:
    BC
    Thanks, that's very comforting
     
  7. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,537
    Likes Received:
    1,486
    Location:
    Sacramento CA
    You have a 5s which was always compatible. @Newly asked about a 5 which is a completely different model than yours.
     
    #7 Oso, Dec 9, 2015
    Last edited: Dec 9, 2015
  8. General Chaos

    Joined:
    Oct 21, 2015
    Messages:
    22
    Likes Received:
    6
    I've also used my iPhone 5 since July with no issues. I use it with the follow me feature.
    I also use an iPad mini 2 when follow me is not needed.
     
  9. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,537
    Likes Received:
    1,486
    Location:
    Sacramento CA
    Let's make this easy so we don't add confusion with so many new pilots coming soon.

    Any Apple device with a processor older than A7 (iphone 5 and older / iPad 4 and older) was not compatible with the app and could not even download to those devices unless they were jail broken. If anyone tried, they would usually get a "device not compatible" error. [Note that iPad 4 is not the same as iPad Mini 4]

    Here is the list of compatible devices from DJI which shows that 5s and later is all that was compatible. Note that IP5 and earlier is not listed.
    20151027 GO app info DJI.JPG

    Once GO 2.4.0 was released on October 23, suddenly devices older than the A7 processor generation were able to download the app without getting the "device not compatible" error. I actually noted as much in a thread at the time just to let people know.

    Like I said before, even though GO can now be downloaded to older devices, IMHO it wont give the best experience. That doesn't mean it wont work, just not well in comparison to more capable devices.
     
    #9 Oso, Dec 9, 2015
    Last edited: Dec 10, 2015